summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-11-07 18:45:21 -0600
committerLuis Martinez2021-11-07 18:45:21 -0600
commitfe387b6c0e995658a41190d937aab58eb4dc5d60 (patch)
tree80efc20aa74299973a6a769740cfe6bedaf8d299
downloadaur-fe387b6c0e995658a41190d937aab58eb4dc5d60.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bdd4255db6f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = neovim-autosave-git
+ pkgdesc = Neovim plugin that auto-saves your work
+ pkgver = r61.140c477
+ pkgrel = 1
+ url = https://github.com/pocco81/autosave.nvim
+ arch = any
+ groups = neovim-plugins
+ license = GPL3
+ makedepends = git
+ depends = neovim>=0.5.0
+ provides = neovim-autosave
+ conflicts = neovim-autosave
+ source = neovim-autosave-git::git+https://github.com/pocco81/autosave.nvim
+ md5sums = SKIP
+
+pkgname = neovim-autosave-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a2fb68cb4b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=neovim-autosave-git
+pkgver=r61.140c477
+pkgrel=1
+pkgdesc="Neovim plugin that auto-saves your work"
+arch=('any')
+url="https://github.com/pocco81/autosave.nvim"
+license=('GPL3')
+groups=('neovim-plugins')
+depends=('neovim>=0.5.0')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ ( set -o pipefail
+ git describe --long --tags 2> /dev/null | sed 's/^v//;s/-/.r/;s/-/./' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "$pkgname"
+ find doc lua plugin -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}