summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-02-26 18:53:33 -0600
committerLuis Martinez2022-02-26 18:53:33 -0600
commit56fa4f2f9dbd012ddc3a81c5c2eb7b3f9ea5ae9a (patch)
treefd0456866f0f933dcf2d2c64940eb5fe6dd157a7
parent52ec119d7505abf411e988ee6a17feddf74b63e4 (diff)
downloadaur-56fa4f2f9dbd012ddc3a81c5c2eb7b3f9ea5ae9a.tar.gz
update to 0.3.1
-rw-r--r--.SRCINFO7
-rw-r--r--CHANGELOG.md83
-rw-r--r--PKGBUILD5
3 files changed, 90 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 517aa79ae61c..ca1813e94921 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = neovim-bqf
pkgdesc = Better quickfix window in Neovim
- pkgver = 0.3.0
+ pkgver = 0.3.1
pkgrel = 1
url = https://github.com/kevinhwang91/nvim-bqf
+ changelog = CHANGELOG.md
arch = any
groups = neovim-plugins
license = BSD
depends = neovim
optdepends = fzf
optdepends = neovim-tree-sitter
- source = neovim-bqf-0.3.0.tar.gz::https://github.com/kevinhwang91/nvim-bqf/archive/v0.3.0.tar.gz
- sha256sums = 241d764e39099692701ae98545a25991415b9793964ea20918573e639c230bf0
+ source = neovim-bqf-0.3.1.tar.gz::https://github.com/kevinhwang91/nvim-bqf/archive/v0.3.1.tar.gz
+ sha256sums = 52aa276e848298c47dde67e86d76e3af118084680b453919a75f75e65eb93843
pkgname = neovim-bqf
diff --git a/CHANGELOG.md b/CHANGELOG.md
new file mode 100644
index 000000000000..29ae1d2551bf
--- /dev/null
+++ b/CHANGELOG.md
@@ -0,0 +1,83 @@
+# Changelog
+
+## [0.3.1] - 2022-02-26
+
+### Bug Fixes
+
+#### FZF
+
+- Support conceal (#56)
+- Add w:quickfix_title as a context/id for spawning headless
+- Clean up tmpfile for preview
+
+#### MagicWin
+
+- Correct the validation of adjacent win session
+
+## [0.3.0] - 2022-02-21
+
+### Bug Fixes
+
+#### FZF
+
+- Should respect UTF-8 as the default value
+- Winbl option should set according by winid
+
+#### MagicWin
+
+- Lose last window cause jumping unexpected window
+- WinClosed in main can't be fired
+- More intelligent
+
+#### Previewer
+
+- Should reset scrolling horizontally
+- Switch tabpage can't fire cursor move
+
+#### Qfwin
+
+- Wrong condition to get previous window
+- Winminwidth must smaller than winwidth (#44)
+- Keep jumplist for jump with drop
+- No error for wiped buffer while jumping
+- Quickfixtextfunc field in list should be supported
+- Avoid extra error while switching list
+- Dispose throwed a error from nvim_buf_del_keymap()
+
+### Documentation
+
+- Add link for integrated plugins
+- Add `:h bqf`
+- Tell you how to make your pretty quickfix window :)
+- Show how to disable fugitive preview automatically
+- Large value for win_height perform full mode (#55)
+
+### Features
+
+#### FFI
+
+- Add ffi module
+
+#### FZF
+
+- Support preview for Windows
+- Support --scroll-off
+- Support --nth=3..,1,2
+- Add `closeall` action
+- Support fzf_extra_opts and fzf_action_for to context
+- Less flicker when start/stop fzf
+
+#### MagicWin
+
+- Support virt_lines
+
+#### Qfwin
+
+- [**breaking**] Change default value of auto_resize_height to `false`
+- [**breaking**] `<` or `>` will jump last leaving position automatically
+- Add last leaving position
+- Add new jump commands (#45)
+
+### Performance
+
+- Cache parsers to speed up preview with treesitter
diff --git a/PKGBUILD b/PKGBUILD
index e0b30546be78..f6f1b44918bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=neovim-bqf
-pkgver=0.3.0
+pkgver=0.3.1
pkgrel=1
pkgdesc="Better quickfix window in Neovim"
arch=('any')
@@ -10,8 +10,9 @@ license=('BSD')
groups=('neovim-plugins')
depends=('neovim')
optdepends=('fzf' 'neovim-tree-sitter')
+changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('241d764e39099692701ae98545a25991415b9793964ea20918573e639c230bf0')
+sha256sums=('52aa276e848298c47dde67e86d76e3af118084680b453919a75f75e65eb93843')
package() {
cd "nvim-bqf-$pkgver"