summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHezekiah Michael2022-10-09 00:32:19 -0400
committerHezekiah Michael2022-10-09 00:32:19 -0400
commit63349757241652f934c93c0c6d08ba9c9fb30227 (patch)
tree43fc2267c503838218a044c1257cd76c95cfc568
downloadaur-63349757241652f934c93c0c6d08ba9c9fb30227.tar.gz
initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD50
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2959004fdfe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = neovim-candid
+ pkgver = r86.f7198b5
+ pkgrel = 1
+ url = https://github.com/flrnd/candid.vim
+ arch = any
+ license = MIT
+ makedepends = git
+ source = neovim-candid::git+https://github.com/flrnd/candid.vim
+ md5sums = SKIP
+
+pkgname = neovim-candid-git
+ pkgdesc = A dark colorscheme with vibrant colors.
+ depends = neovim
+ optdepends = neovim-lightline-git: for lightline color scheme
+ optdepends = md2vim: to make candid.txt help file
+ provides = neovim-candid
+ conflicts = neovim-candid
+
+pkgname = neovim-lightline-candid-git
+ pkgdesc = Candid color scheme for lightline.
+ depends = neovim
+ depends = neovim-candid
+ optdepends = neovim-lightline-git
+ provides = neovim-lightline-candid
+ conflicts = neovim-lightline-candid
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e654861089b9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+neovim-candid
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef2a984be171
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Hezekiah Michael <spiritomb at protonmail dot com>
+
+pkgbase=neovim-candid
+pkgname=('neovim-candid-git'
+ 'neovim-lightline-candid-git')
+pkgver=r86.f7198b5
+pkgrel=1
+arch=('any')
+url="https://github.com/flrnd/candid.vim"
+license=('MIT')
+makedepends=('git')
+source=("${pkgbase}::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgbase}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package_neovim-candid-git() {
+ pkgdesc="A dark colorscheme with vibrant colors."
+ _pkgname=neovim-candid
+ depends=('neovim')
+ optdepends=('neovim-lightline-git: for lightline color scheme'
+ 'md2vim: to make candid.txt help file')
+ provides=("${pkgbase}")
+ conflicts=("${pkgbase}")
+ cd "${srcdir}/${pkgbase}"
+ find autoload/candid.vim colors \
+ -type f -exec install -Dm 644 '{}' "${pkgdir}/usr/share/nvim/runtime/pack/candid.vim/start/candid.vim/{}" \;
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/${_pkgname}/"
+ which md2vim > /dev/null
+ if [[ $? == 0 ]]; then
+ md2vim README.md candid.txt
+ install -Dm 644 candid.txt -t "$pkgdir/usr/share/nvim/runtime/doc/"
+ rm candid.txt
+ fi
+}
+
+package_neovim-lightline-candid-git() {
+ pkgdesc="Candid color scheme for lightline."
+ depends=('neovim' 'neovim-candid')
+ optdepends=('neovim-lightline-git')
+ _pkgname=neovim-lightline-candid
+ provides=('neovim-lightline-candid')
+ conflicts=('neovim-lightline-candid')
+ cd "${srcdir}/${pkgbase}"
+ find autoload/lightline -type f -exec \
+ install -Dm 644 '{}' "${pkgdir}/usr/share/nvim/runtime/{}" \;
+}