summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-08-06 21:41:06 -0500
committerLuis Martinez2022-08-06 21:41:06 -0500
commitc4bb3d336327f936243b0be73451c5890e21ab0c (patch)
tree9ebdc0d322ae5ba15a3db7d3df186043451eed9d
downloadaur-c4bb3d336327f936243b0be73451c5890e21ab0c.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
-rw-r--r--catppuccin.install9
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..466efdb0622f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = neovim-catppuccin-git
+ pkgdesc = Soothing pastel theme for Neovim
+ pkgver = r932.7f5a866
+ pkgrel = 1
+ url = https://github.com/catppuccin/nvim
+ install = catppuccin.install
+ arch = any
+ groups = neovim-plugins
+ license = MIT
+ makedepends = git
+ depends = neovim
+ provides = neovim-catppuccin
+ conflicts = neovim-catppuccin
+ source = neovim-catppuccin::git+https://github.com/catppuccin/nvim
+ sha256sums = SKIP
+
+pkgname = neovim-catppuccin-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2fc66de5652
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=neovim-catppuccin-git
+_pkg="${pkgname%-git}"
+pkgver=r932.7f5a866
+pkgrel=1
+pkgdesc="Soothing pastel theme for Neovim"
+arch=('any')
+url="https://github.com/catppuccin/nvim"
+license=('MIT')
+groups=('neovim-plugins')
+depends=('neovim')
+makedepends=('git')
+provides=("$_pkg")
+conflicts=("$_pkg")
+install=catppuccin.install
+source=("$_pkg::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkg"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" )
+}
+
+package() {
+ cd "$_pkg"
+ find autoload colors doc lua plugin -type f -exec install -Dm644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
diff --git a/catppuccin.install b/catppuccin.install
new file mode 100644
index 000000000000..88714b4dba41
--- /dev/null
+++ b/catppuccin.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo ':: This plugin requires manual setup.'
+ echo ':: Consult upstream documentation for more information.'
+ echo ':: A copy has been installed under /usr/share/doc/neovim-catppuccin-git/README.md for your reference.'
+}
+
+post_remove() {
+ echo ':: Remember to remove all references to this plugin from your init scripts.'
+}