summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-10-13 21:54:47 -0500
committerLuis Martinez2021-10-14 01:00:18 -0500
commit5d97d7ac2ba8f091d2639fa1bbdecc5e75247dc5 (patch)
tree6bf75d033e69f11e5db63b908a918e336a1ae178
downloadaur-5d97d7ac2ba8f091d2639fa1bbdecc5e75247dc5.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
-rw-r--r--cmp-buffer.install9
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a7d4d89dbf1a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = neovim-cmp-buffer-git
+ pkgdesc = neovim-cmp source for buffer words
+ pkgver = r13.5dde543
+ pkgrel = 1
+ url = https://github.com/hrsh7th/cmp-buffer
+ install = cmp-buffer.install
+ arch = any
+ groups = neovim-plugin
+ license = custom:unknown
+ makedepends = git
+ depends = neovim-cmp
+ provides = neovim-cmp-buffer
+ conflicts = neovim-cmp-buffer
+ source = neovim-cmp-buffer-git::git+https://github.com/hrsh7th/cmp-buffer
+ md5sums = SKIP
+
+pkgname = neovim-cmp-buffer-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ceb37036fed6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=neovim-cmp-buffer-git
+pkgver=r13.5dde543
+pkgrel=1
+pkgdesc="neovim-cmp source for buffer words"
+arch=('any')
+url="https://github.com/hrsh7th/cmp-buffer"
+license=('custom:unknown')
+groups=('neovim-plugin')
+depends=('neovim-cmp')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install=cmp-buffer.install
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+package() {
+ cd "$pkgname"
+ find after lua -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/nvim/runtime/pack/dist/start/$pkgname/{}" \;
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
diff --git a/cmp-buffer.install b/cmp-buffer.install
new file mode 100644
index 000000000000..d166254eaed6
--- /dev/null
+++ b/cmp-buffer.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo ':: This plugin requires manual setup.'
+ echo ':: Consult upstream documentation for more information.'
+ echo ':: A copy has been installed under /usr/share/doc/neovim-cmp-buffer-git/README.md for your reference.'
+}
+
+post_remove() {
+ echo ':: Remember to remove all references to this plugin from your init scripts.'
+}