summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDamien Tardy-Panis2024-03-15 22:21:46 +0100
committerDamien Tardy-Panis2024-03-15 22:21:46 +0100
commitcc6790e1bc5cf00f87ddafec78b96f32602cb118 (patch)
treeabf3eea17d494352fc0e911156d3007c0cdf6f52
parent5d97d7ac2ba8f091d2639fa1bbdecc5e75247dc5 (diff)
downloadaur-cc6790e1bc5cf00f87ddafec78b96f32602cb118.tar.gz
Cleanup build
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD46
-rw-r--r--cmp-buffer.install9
3 files changed, 35 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7d4d89dbf1a..3d01248cf09b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
pkgbase = neovim-cmp-buffer-git
pkgdesc = neovim-cmp source for buffer words
- pkgver = r13.5dde543
+ pkgver = r53.3022dbc
pkgrel = 1
url = https://github.com/hrsh7th/cmp-buffer
- install = cmp-buffer.install
arch = any
- groups = neovim-plugin
- license = custom:unknown
+ groups = neovim-plugins
+ license = MIT
makedepends = git
- depends = neovim-cmp
- provides = neovim-cmp-buffer
- conflicts = neovim-cmp-buffer
- source = neovim-cmp-buffer-git::git+https://github.com/hrsh7th/cmp-buffer
- md5sums = SKIP
+ source = git+https://github.com/hrsh7th/cmp-buffer.git
+ sha512sums = SKIP
pkgname = neovim-cmp-buffer-git
+ depends = neovim
diff --git a/PKGBUILD b/PKGBUILD
index ceb37036fed6..85a473f5ab06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,39 @@
-# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
-
pkgname=neovim-cmp-buffer-git
-pkgver=r13.5dde543
+pkgver=r53.3022dbc
pkgrel=1
pkgdesc="neovim-cmp source for buffer words"
arch=('any')
url="https://github.com/hrsh7th/cmp-buffer"
-license=('custom:unknown')
-groups=('neovim-plugin')
-depends=('neovim-cmp')
-makedepends=('git')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-install=cmp-buffer.install
-source=("$pkgname::git+$url")
-md5sums=('SKIP')
+license=('MIT')
+
+groups=(
+ 'neovim-plugins'
+)
+
+makedepends=(
+ 'git'
+)
+
+source=(
+ "git+https://github.com/hrsh7th/cmp-buffer.git"
+)
+
+sha512sums=(
+ 'SKIP'
+)
pkgver() {
- cd "$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd cmp-buffer
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+
package() {
- cd "$pkgname"
- find after lua -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/nvim/runtime/pack/dist/start/$pkgname/{}" \;
- install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+ depends+=(
+ 'neovim'
+ )
+
+ cd cmp-buffer
+ find after lua -type f -exec install -D -m644 '{}' "$pkgdir/usr/share/nvim/site/pack/dist/start/${pkgname}/{}" \;
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
}
diff --git a/cmp-buffer.install b/cmp-buffer.install
deleted file mode 100644
index d166254eaed6..000000000000
--- a/cmp-buffer.install
+++ /dev/null
@@ -1,9 +0,0 @@
-post_install() {
- echo ':: This plugin requires manual setup.'
- echo ':: Consult upstream documentation for more information.'
- echo ':: A copy has been installed under /usr/share/doc/neovim-cmp-buffer-git/README.md for your reference.'
-}
-
-post_remove() {
- echo ':: Remember to remove all references to this plugin from your init scripts.'
-}