summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-08-14 16:01:27 -0500
committerLuis Martinez2022-08-14 16:01:27 -0500
commit87e4330c52c3b736493fb0a74a545be56eda5880 (patch)
treef686b27a88b24087cab69a904d57df94522bce72
parentbb3bf54711f64b1faea93323a12ab4d966605cec (diff)
downloadaur-87e4330c52c3b736493fb0a74a545be56eda5880.tar.gz
packaging update
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD20
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b6cef87ef34..d367aa21d1b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = neovim-cmp-git
pkgdesc = Autocompletion plugin for Neovim
- pkgver = r252.f5393d5
+ pkgver = 0.0.1.r3.gb1ebdb0
pkgrel = 1
url = https://github.com/hrsh7th/nvim-cmp
install = cmp.install
@@ -8,7 +8,7 @@ pkgbase = neovim-cmp-git
groups = neovim-plugins
license = MIT
makedepends = git
- depends = neovim>=0.5.0
+ depends = neovim
optdepends = neovim-cmp-nvim-lsp: source for Neovim builtin LSP client
optdepends = neovim-cmp-buffer: buffer autocompletion
optdepends = neovim-cmp-path: path autocompletion
diff --git a/PKGBUILD b/PKGBUILD
index 4a43ae779884..c50a8dee9711 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=neovim-cmp-git
-pkgver=r252.f5393d5
+_pkg="${pkgname%-git}"
+pkgver=0.0.1.r3.gb1ebdb0
pkgrel=1
pkgdesc="Autocompletion plugin for Neovim"
arch=('any')
url="https://github.com/hrsh7th/nvim-cmp"
license=('MIT')
groups=('neovim-plugins')
-depends=('neovim>=0.5.0')
+depends=('neovim')
optdepends=(
'neovim-cmp-nvim-lsp: source for Neovim builtin LSP client'
'neovim-cmp-buffer: buffer autocompletion'
@@ -18,20 +19,21 @@ optdepends=(
'neovim-cmp-omni: omnifunc autocompletion'
'neovim-cmp-vsnip: vsnip autocompletion')
makedepends=('git')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
+provides=("$_pkg")
+conflicts=("$_pkg")
install=cmp.install
source=("$pkgname::git+$url")
sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git -C "$pkgname" describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
}
package() {
cd "$pkgname"
- find autoload lua plugin -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/nvim/runtime/pack/dist/start/$pkgname/{}" \;
- install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
- install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+ find autoload lua plugin \
+ -type f \
+ -exec install -Dm644 '{}' "$pkgdir/usr/share/nvim/runtime/pack/dist/start/$pkgname/{}" \;
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
}