summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-10-25 09:08:12 -0500
committerLuis Martinez2021-10-25 09:08:12 -0500
commit8c7c3679c7a8101ce89b5751124e969a62226de2 (patch)
treef7b8a3c8bb1dbeebdc85907eaeaa5b7df0359f78
downloadaur-8c7c3679c7a8101ce89b5751124e969a62226de2.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
-rw-r--r--cmp-npm.install9
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..70ff345f2aea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = neovim-cmp-npm-git
+ pkgdesc = npm source for neovim-cmp
+ pkgver = r15.c412be1
+ pkgrel = 1
+ url = https://github.com/david-kunz/cmp-npm
+ install = cmp-npm.install
+ arch = any
+ groups = neovim-plugins
+ license = Unlicense
+ makedepends = git
+ depends = neovim-cmp
+ depends = neovim-plenary
+ depends = npm
+ provides = neovim-cmp-npm
+ conflicts = neovim-cmp-npm
+ source = neovim-cmp-npm-git::git+https://github.com/david-kunz/cmp-npm
+ md5sums = SKIP
+
+pkgname = neovim-cmp-npm-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..826f181ba232
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=neovim-cmp-npm-git
+pkgver=r15.c412be1
+pkgrel=1
+pkgdesc="npm source for neovim-cmp"
+arch=('any')
+url="https://github.com/david-kunz/cmp-npm"
+license=('Unlicense')
+groups=('neovim-plugins')
+depends=('neovim-cmp' 'neovim-plenary' 'npm')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install=cmp-npm.install
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+PURGE_TARGETS=('.DS_Store')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ find lua -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/nvim/runtime/pack/dist/start/${pkgname%-git}/{}" \;
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
diff --git a/cmp-npm.install b/cmp-npm.install
new file mode 100644
index 000000000000..6f56fc1999bd
--- /dev/null
+++ b/cmp-npm.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo ':: This plugin requires manual setup.'
+ echo ':: Consult upstream documentation for more information.'
+ echo ':: A copy has been installed under /usr/share/doc/neovim-cmp-npm-git/README.md for your reference.'
+}
+
+post_remove() {
+ echo ':: Remember to remove all references to this plugin from your init scripts.'
+}