summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShane Stone2024-02-13 20:44:35 -0500
committerShane Stone2024-02-13 20:44:35 -0500
commitb779be2e432513c7cafcf7c8692f7c45543f8306 (patch)
tree935b231f3d0ffb5d5a4f93689d32fc40aa912a8b
downloadaur-neovim-cmp-opt-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2d3ee6e9cbad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = neovim-cmp-opt-git
+ pkgdesc = A completion engine plugin for neovim written in Lua.
+ pkgver = 703.e1f1b40
+ pkgrel = 1
+ url = https://github.com/hrsh7th/nvim-cmp
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = neovim
+ source = cmp::git+https://github.com/hrsh7th/nvim-cmp.git
+ sha256sums = SKIP
+
+pkgname = neovim-cmp-opt-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8963a4240709
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+pkgname=neovim-cmp-opt-git
+_pkgname=cmp
+pkgver=703.e1f1b40
+pkgrel=1
+pkgdesc='A completion engine plugin for neovim written in Lua.'
+arch=('any')
+url="https://github.com/hrsh7th/nvim-cmp"
+license=('MIT')
+depends=('neovim')
+makedepends=('git')
+source=("${_pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+
+ cd "${srcdir}/${_pkgname}"
+
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+
+}
+
+package() {
+
+ cd "${srcdir}/${_pkgname}"
+
+local _installpath="usr/local/share/nvim/site/pack/${_pkgname}/opt/${_pkgname}"
+
+ install -dvm755 "${pkgdir}/${_installpath}"
+
+ cp -rt "${pkgdir}/${_installpath}" autoload doc lua plugin utils
+
+}