summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-10-26 22:00:48 -0500
committerLuis Martinez2021-10-26 22:00:48 -0500
commite6c913425d23ca528a4f20602a1837df63895515 (patch)
treee4c743b350b579507dcb3ec15df020bbf68f34bb
downloadaur-e6c913425d23ca528a4f20602a1837df63895515.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
-rw-r--r--cmp-treesitter.install9
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..041cc8b75089
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = neovim-cmp-treesitter-git
+ pkgdesc = neovim-cmp source for treesitter
+ pkgver = r10.0ba0a99
+ pkgrel = 1
+ url = https://github.com/ray-x/cmp-treesitter
+ install = cmp-treesitter.install
+ arch = any
+ groups = neovim-plugins
+ license = GPL3
+ makedepends = git
+ depends = neovim-cmp
+ depends = tree-sitter
+ provides = neovim-cmp-treesitter
+ conflicts = neovim-cmp-treesitter
+ source = neovim-cmp-treesitter-git::git+https://github.com/ray-x/cmp-treesitter
+ md5sums = SKIP
+
+pkgname = neovim-cmp-treesitter-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..55998e376440
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=neovim-cmp-treesitter-git
+pkgver=r10.0ba0a99
+pkgrel=1
+pkgdesc="neovim-cmp source for treesitter"
+arch=('any')
+url="https://github.com/ray-x/cmp-treesitter"
+license=('GPL3')
+groups=('neovim-plugins')
+depends=('neovim-cmp' 'tree-sitter')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install=cmp-treesitter.install
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ find after lua -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/nvim/runtime/pack/dist/start/$pkgname/{}" \;
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
diff --git a/cmp-treesitter.install b/cmp-treesitter.install
new file mode 100644
index 000000000000..55ce543e75de
--- /dev/null
+++ b/cmp-treesitter.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo ':: This plugin requires manual setup.'
+ echo ':: Consult upstream documentation for more information.'
+ echo ':: A copy has been installed under /usr/share/doc/neovim-cmp-treesitter-git/README.md for your reference.'
+}
+
+post_remove() {
+ echo ':: Remember to remove all references to this plugin from your init scripts.'
+}