summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-10-25 09:28:20 -0500
committerLuis Martinez2021-10-25 09:28:20 -0500
commitda70cb6c9e4dba810405b70a8701bfae674d1ef7 (patch)
treee7f10a6747c2139f72c417c2231bbf954d501c14
downloadaur-da70cb6c9e4dba810405b70a8701bfae674d1ef7.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD29
-rw-r--r--cmp-git.install9
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9587e9af1a1e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = neovim-cmp_git-git
+ pkgdesc = Git source for neovim-cmp
+ pkgver = r27.501f910
+ pkgrel = 1
+ url = https://github.com/petertriho/cmp-git
+ install = cmp-git.install
+ arch = any
+ groups = neovim-plugins
+ license = MIT
+ depends = neovim-cmp
+ depends = neovim-plenary
+ depends = git
+ depends = curl
+ optdepends = github-cli
+ optdepends = gitlab
+ provides = neovim-cmp_git
+ conflicts = neovim-cmp_git
+ source = neovim-cmp_git-git::git+https://github.com/petertriho/cmp-git
+ md5sums = SKIP
+
+pkgname = neovim-cmp_git-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b8f3dbafae4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=neovim-cmp_git-git
+pkgver=r27.501f910
+pkgrel=1
+pkgdesc="Git source for neovim-cmp"
+arch=('any')
+url="https://github.com/petertriho/cmp-git"
+license=('MIT')
+groups=('neovim-plugins')
+depends=('neovim-cmp' 'neovim-plenary' 'git' 'curl')
+optdepends=('github-cli' 'gitlab')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install=cmp-git.install
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ find lua -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/nvim/runtime/pack/dist/start/${pkgname%-git}/{}" \;
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
diff --git a/cmp-git.install b/cmp-git.install
new file mode 100644
index 000000000000..6a2ce11aa554
--- /dev/null
+++ b/cmp-git.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo ':: This plugin requires manual setup.'
+ echo ':: Consult upstream documentation for more information.'
+ echo ':: A copy has been installed under /usr/share/doc/neovim-cmp_git-git/README.md for your reference.'
+}
+
+post_remove() {
+ echo ':: Remember to remove all references to this plugin from your init scripts.'
+}