summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhe Park2022-05-27 17:18:23 +0800
committerSainnhe Park2022-05-27 17:18:23 +0800
commit45d090afee7ce773d30c953c7ca78d5aedf3bc56 (patch)
treeb5eae3a61ae440836b0a9e9834cea0f3be6a5761
parent2c36a5d167a384a824764a2e6f0a09e2e7d9859c (diff)
downloadaur-45d090afee7ce773d30c953c7ca78d5aedf3bc56.tar.gz
Update to 0.0.81
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8914bf0bda4..05bfef096880 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = neovim-coc
pkgdesc = Intellisense engine for Vim8 & Neovim, full language server protocol support as VSCode
- pkgver = 0.0.80
- pkgrel = 4
+ pkgver = 0.0.81
+ pkgrel = 1
url = https://github.com/neoclide/coc.nvim
arch = any
license = MIT
@@ -13,8 +13,7 @@ pkgbase = neovim-coc
optdepends = watchman: for workspace_didChangeWatchedFiles feature
provides = neovim-coc
conflicts = neovim-coc
- source = https://github.com/neoclide/coc.nvim/archive/c90a07eec847d38909702454c9e096ac6d392aff.zip
- sha256sums = 3942014f681bfe2b25f3653fbb1108dbaf1de9f4f6993e9770a7fd42a92014f2
+ source = https://github.com/neoclide/coc.nvim/archive/21a8e00b3c62faca4fdda5fa16b4f3ed4c03cf09.zip
+ sha256sums = 97374516741d70615a0878a7072307fe58e13f4d13333fb67f88a8f706972c76
pkgname = neovim-coc
-
diff --git a/PKGBUILD b/PKGBUILD
index 2a0f8c5f9751..5b9d766f1459 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Sainnhe Park <sainnhe@gmail.com>
pkgname=neovim-coc
# Coc.nvim creates tags on release branch but the source code is only available on master branch, so I have to use commit hash to specify the version to use.
-_hash='c90a07eec847d38909702454c9e096ac6d392aff'
-pkgver=0.0.80
-pkgrel=4
+_hash='21a8e00b3c62faca4fdda5fa16b4f3ed4c03cf09'
+pkgver=0.0.81
+pkgrel=1
pkgdesc='Intellisense engine for Vim8 & Neovim, full language server protocol support as VSCode'
arch=('any')
url='https://github.com/neoclide/coc.nvim'
@@ -16,11 +16,10 @@ makedepends=('yarn')
provides=('neovim-coc')
conflicts=('neovim-coc')
source=("https://github.com/neoclide/coc.nvim/archive/${_hash}.zip")
-sha256sums=('3942014f681bfe2b25f3653fbb1108dbaf1de9f4f6993e9770a7fd42a92014f2')
+sha256sums=('97374516741d70615a0878a7072307fe58e13f4d13333fb67f88a8f706972c76')
build() {
cd "${srcdir}/coc.nvim-${_hash}"
- sed -i "3s/=.*/= '${_hash}'/" webpack.config.js
yarn install --frozen-lockfile --preferred-cache-folder "${srcdir}/.cache"
}