summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhe Park2021-03-26 18:53:13 +0800
committerSainnhe Park2021-03-26 18:53:13 +0800
commit60026703cf52f01fc1082b7f9258602db648cecb (patch)
treea2d11e9b2e3d06c4d02eeee6fc647f1205ee6781
parent72405a96bb944932f3e40dd426fe3d363c83270a (diff)
downloadaur-60026703cf52f01fc1082b7f9258602db648cecb.tar.gz
Compile from master branch
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD24
2 files changed, 20 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab40b6a2927f..f8914bf0bda4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = neovim-coc
pkgdesc = Intellisense engine for Vim8 & Neovim, full language server protocol support as VSCode
pkgver = 0.0.80
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/neoclide/coc.nvim
arch = any
license = MIT
+ makedepends = yarn
depends = neovim
depends = nodejs
optdepends = npm: for installing coc extensions
optdepends = yarn: for installing coc extensions
optdepends = watchman: for workspace_didChangeWatchedFiles feature
- optdepends = neovim-coc-extras-meta: some basic extensions
provides = neovim-coc
conflicts = neovim-coc
- source = https://github.com/neoclide/coc.nvim/archive/v0.0.80.tar.gz
- sha256sums = 6bc817a8fcb42ed4ce139bb128a0087520be1c73d197968b163e9125c9a80ba6
+ source = https://github.com/neoclide/coc.nvim/archive/c90a07eec847d38909702454c9e096ac6d392aff.zip
+ sha256sums = 3942014f681bfe2b25f3653fbb1108dbaf1de9f4f6993e9770a7fd42a92014f2
pkgname = neovim-coc
diff --git a/PKGBUILD b/PKGBUILD
index 648a0fcc983f..29d5d0e203ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,9 @@
# Maintainer: Sainnhe Park <sainnhe@gmail.com>
pkgname=neovim-coc
+# Coc.nvim creates tags on release branch but the source code is only available on master branch, so I have to use commit hash to specify the version to use.
+_hash='c90a07eec847d38909702454c9e096ac6d392aff'
pkgver=0.0.80
-pkgrel=3
+pkgrel=4
pkgdesc='Intellisense engine for Vim8 & Neovim, full language server protocol support as VSCode'
arch=('any')
url='https://github.com/neoclide/coc.nvim'
@@ -9,18 +11,24 @@ license=('MIT')
depends=('neovim' 'nodejs')
optdepends=('npm: for installing coc extensions'
'yarn: for installing coc extensions'
- 'watchman: for workspace_didChangeWatchedFiles feature'
- 'neovim-coc-extras-meta: some basic extensions')
+ 'watchman: for workspace_didChangeWatchedFiles feature')
+makedepends=('yarn')
provides=('neovim-coc')
conflicts=('neovim-coc')
-source=("https://github.com/neoclide/coc.nvim/archive/v${pkgver}.tar.gz")
-sha256sums=('6bc817a8fcb42ed4ce139bb128a0087520be1c73d197968b163e9125c9a80ba6')
+source=("https://github.com/neoclide/coc.nvim/archive/${_hash}.zip")
+sha256sums=('3942014f681bfe2b25f3653fbb1108dbaf1de9f4f6993e9770a7fd42a92014f2')
+
+build() {
+ cd "${srcdir}/coc.nvim-${_hash}"
+ yarn install --frozen-lockfile --preferred-cache-folder "${srcdir}/.cache"
+ yarn run build
+}
package() {
- cd "${srcdir}/coc.nvim-${pkgver}"
+ cd "${srcdir}/coc.nvim-${_hash}"
nvim -es --cmd ":helptags doc" --cmd ":q"
- find autoload bin build data doc package.json plugin -type f -exec \
+ find autoload build data doc package.json plugin -type f -exec \
install -Dm 644 '{}' "${pkgdir}/usr/share/nvim/runtime/pack/coc/start/coc.nvim/{}" \;
- install -Dm 644 "${srcdir}/coc.nvim-${pkgver}/LICENSE.md" \
+ install -Dm 644 "${srcdir}/coc.nvim-${_hash}/LICENSE.md" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
}