summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhe Park2023-01-31 21:01:08 +0800
committerSainnhe Park2023-01-31 21:01:08 +0800
commit866166d19d42e201ce6ef4a7a88fc3604de9a90e (patch)
treeeb6442175411ee5441917cc79506823130506a0d
parent6e2c520db9d437cda8e5f2ae9a4b2168104c7d5e (diff)
downloadaur-866166d19d42e201ce6ef4a7a88fc3604de9a90e.tar.gz
Install to opt dir
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3ba2ef6968c..db1ecd441de5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = neovim-coc
pkgdesc = Intellisense engine for Vim8 & Neovim, full language server protocol support as VSCode
pkgver = 0.0.82
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/neoclide/coc.nvim
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index efc45b177360..70c64a186046 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=neovim-coc
# Coc.nvim creates tags on release branch but the source code is only available on master branch, so I have to use commit hash to specify the version to use.
_hash='7a50d4d9513362aa21cf42646ceca0cb41cb0dbc'
pkgver=0.0.82
-pkgrel=3
+pkgrel=4
pkgdesc='Intellisense engine for Vim8 & Neovim, full language server protocol support as VSCode'
arch=('any')
url='https://github.com/neoclide/coc.nvim'
@@ -27,7 +27,7 @@ package() {
cd "${srcdir}/coc.nvim-${_hash}"
nvim -es --cmd ":helptags doc" --cmd ":q"
find autoload build data doc package.json plugin -type f -exec \
- install -Dm 644 '{}' "${pkgdir}/usr/share/nvim/runtime/pack/coc/start/coc.nvim/{}" \;
+ install -Dm 644 '{}' "${pkgdir}/usr/share/nvim/runtime/pack/coc/opt/coc.nvim/{}" \;
install -Dm 644 "${srcdir}/coc.nvim-${_hash}/LICENSE.md" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
}