summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-10-23 12:15:04 +0800
committerSainnhepark2020-10-23 12:15:04 +0800
commitfe6236c431be6c861886f6fdf11795feda8a6373 (patch)
treed6c9f6a0fa437717e75f746d8ac39ca4991c20fa
parentde4e1e2d588c967f29770c08c50b43eff73123f3 (diff)
downloadaur-fe6236c431be6c861886f6fdf11795feda8a6373.tar.gz
add license
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5bee369690e3..e5c2f71b2cca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = neovim-coc-clangd-git
pkgdesc = C/C++/ObjC support for coc.nvim (powered by clangd)
- pkgver = r101.0a6fc9f
+ pkgver = r116.a3650f2
pkgrel = 1
url = https://github.com/clangd/coc-clangd
arch = any
- license =
+ license = Apache
makedepends = yarn
makedepends = npm
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index 5f01696ab7f2..4130dab76386 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,9 +11,9 @@ conflicts=("${_variant}-${_extname}")
arch=('any')
depends=("${_variant}-coc" 'clang')
makedepends=('yarn' 'npm' 'git')
-license=('')
+license=('Apache')
source=("${_extname}::git+${url}.git")
-pkgver=r101.0a6fc9f
+pkgver=r116.a3650f2
pkgrel=1
sha256sums=('SKIP')
@@ -24,12 +24,12 @@ pkgver() {
build() {
cd "${srcdir}/${_extname}"
- yarn install --frozen-lockfile
+ yarn install --frozen-lockfile --preferred-cache-folder "${srcdir}/.cache/yarn"
yarn pack
tar xvf *.tgz
rm *.tgz
cd package
- npm install --only=production --no-lockfile --ignore-scripts
+ npm install --only=production --no-lockfile --ignore-scripts --cache "${srcdir}/.cache/npm"
}
package() {
@@ -37,4 +37,6 @@ package() {
find . -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
rm -rf "${srcdir}/${_extname}/package"
+ find "$pkgdir" -name package.json -print0 | xargs -r -0 sed -i '/_where/d'
+ chown -R root:root "${pkgdir}"
}