summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-07-27 10:06:30 +0800
committerSainnhepark2020-07-27 10:06:30 +0800
commit8e7a2397b586bea6d0f9f2710366a4633df9e8a1 (patch)
treeac791c5f7660efaa13eec62abd261ed56c9d2c85
parentff5e79e89df6ce79e2f9106108774f81fb9d0d18 (diff)
downloadaur-8e7a2397b586bea6d0f9f2710366a4633df9e8a1.tar.gz
add hook to generate helptags
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--coc-neovim-doc.hook11
3 files changed, 25 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9815931e3e8d..a52bc097b64d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = neovim-coc-git
pkgdesc = Intellisense engine for Vim8 & Neovim, full language server protocol support as VSCode
pkgver = v0.0.78.r106.g140321e6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/neoclide/coc.nvim
arch = any
license = MIT
@@ -13,7 +13,9 @@ pkgbase = neovim-coc-git
provides = neovim-coc
conflicts = neovim-coc
source = git+https://github.com/neoclide/coc.nvim.git#branch=release
+ source = coc-neovim-doc.hook
sha256sums = SKIP
+ sha256sums = 70cd7d959ea6ca973bd761b6deab922bfa34dd725aab636a0bbc5fbfd60cabaa
pkgname = neovim-coc-git
diff --git a/PKGBUILD b/PKGBUILD
index f98b92584e64..4ff119f74995 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Sainnhe Park <sainnhe@gmail.com>
pkgname=neovim-coc-git
pkgver=v0.0.78.r106.g140321e6
-pkgrel=1
+pkgrel=2
pkgdesc='Intellisense engine for Vim8 & Neovim, full language server protocol support as VSCode'
arch=('any')
url='https://github.com/neoclide/coc.nvim'
@@ -11,18 +11,26 @@ optdepends=('npm: for installing coc extensions' 'yarn: for installing coc exten
makedepends=('git')
provides=('neovim-coc')
conflicts=('neovim-coc')
-source=('git+https://github.com/neoclide/coc.nvim.git#branch=release')
-sha256sums=('SKIP')
+source=('git+https://github.com/neoclide/coc.nvim.git#branch=release'
+ 'coc-neovim-doc.hook')
+sha256sums=('SKIP'
+ '70cd7d959ea6ca973bd761b6deab922bfa34dd725aab636a0bbc5fbfd60cabaa')
pkgver() {
cd "${srcdir}/coc.nvim"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+build() {
+ cd "${srcdir}/coc.nvim"
+ touch doc/tags doc/tags-cn
+}
+
package() {
cd "${srcdir}/coc.nvim"
find autoload bin build data doc package.json plugin -type f -exec \
install -Dm 644 '{}' "${pkgdir}/usr/share/nvim/runtime/pack/coc/start/coc.nvim/{}" \;
install -Dm 644 "${srcdir}/coc.nvim/LICENSE.md" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+ install -Dm 644 "${srcdir}"/coc-neovim-doc.hook "${pkgdir}"/usr/share/libalpm/hooks/coc-neovim-doc.hook
}
diff --git a/coc-neovim-doc.hook b/coc-neovim-doc.hook
new file mode 100644
index 000000000000..8351ddd27b37
--- /dev/null
+++ b/coc-neovim-doc.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Operation = Install
+Operation = Upgrade
+Operation= Remove
+Type = Path
+Target = usr/share/nvim/runtime/pack/coc/start/coc.nvim/doc/
+
+[Action]
+Description = Updating Vim help tags...
+Exec = /usr/bin/nvim -es --cmd ":helptags /usr/share/nvim/runtime/pack/coc/start/coc.nvim/doc" --cmd ":q"
+When = PostTransaction