summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-11-05 21:12:41 +0800
committerSainnhepark2020-11-05 21:12:41 +0800
commit0207f966a7e6c33cfb7b8bed66163ef6669cbf55 (patch)
treed77afc3c4860e6096294c49d2e1bf7770c050f57
parent714e7ba2da5d39b8f874405cd5fd9ccccd6410f7 (diff)
downloadaur-0207f966a7e6c33cfb7b8bed66163ef6669cbf55.tar.gz
use yarn to install dependences
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f217d05a21b4..108ef9d9aacb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,16 +24,17 @@ pkgver() {
build() {
cd "${srcdir}/${_extname}"
- yarn install --frozen-lockfile --preferred-cache-folder "${srcdir}/.cache/yarn"
- yarn pack
- tar xvf *.tgz
- rm *.tgz
- cd package
- npm install --only=production --no-lockfile --ignore-scripts --cache "${srcdir}/.cache/npm"
+ yarn install --frozen-lockfile --preferred-cache-folder "${srcdir}/.cache"
}
package() {
- cd "${srcdir}/${_extname}/package"
+ cd "${srcdir}/${_extname}"
+ yarn pack; tar xvf *.tgz; rm *.tgz
+ cd package
+ _dependencies=$(grep -Po '"dependencies":' package.json) || _dependencies=""
+ if [ -n "${_dependencies}" ]; then
+ yarn install --production --no-lockfile --ignore-scripts --prefer-offline --preferred-cache-folder "${srcdir}/.cache"
+ fi
find . -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
rm -rf "${srcdir}/${_extname}/package"