summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-07-28 16:28:46 +0800
committerSainnhepark2020-07-28 16:28:46 +0800
commit2b942d7054de26aaf95c6460914a7f45f6c289f3 (patch)
tree3d411019a05c8010e13de5ddd25ddbdcd1b1ff8c
parente7be363f271ccdf4268d16c0f998eaff268bf326 (diff)
downloadaur-2b942d7054de26aaf95c6460914a7f45f6c289f3.tar.gz
update build()
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index af84cc9a02f9..6faa00134613 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,10 +25,16 @@ pkgver() {
build() {
cd "${srcdir}/${_extname}"
yarn install --frozen-lockfile
+ yarn pack --frozen-lockfile --production
+ tar xvf *.tgz
+ rm *.tgz
+ cd package
+ yarn install --frozen-lockfile --production
}
package() {
- cd "${srcdir}/${_extname}"
- find lib/*.js package.json -type f -exec \
+ cd "${srcdir}/${_extname}/package"
+ find . -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
+ rm -rf "${srcdir}/${_extname}/package"
}