summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-07-28 08:57:51 +0800
committerSainnhepark2020-07-28 08:57:51 +0800
commit7f2a5d0524d77d48494cccfa123430c320742201 (patch)
tree771515a98d51d039791381b32e4c7f0934a355c0
downloadaur-7f2a5d0524d77d48494cccfa123430c320742201.tar.gz
init
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..18cea8e135e6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = neovim-coc-highlight-git
+ pkgdesc = Document highlight and document colors LSP support for coc.nvim
+ pkgver = 1.2.5.r2.gb4e82eb
+ pkgrel = 1
+ url = https://github.com/neoclide/coc-highlight
+ arch = any
+ groups = neovim-coc-extras-git
+ license =
+ makedepends = git
+ makedepends = yarn
+ makedepends = npm
+ depends = neovim-coc
+ provides = neovim-coc-highlight
+ conflicts = neovim-coc-highlight
+ source = coc-highlight::git+https://github.com/neoclide/coc-highlight.git
+ sha256sums = SKIP
+
+pkgname = neovim-coc-highlight-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5bc3f49d265b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Sainnhe Park <sainnhe@gmail.com>
+pkgname=neovim-coc-highlight-git
+_pkgname=neovim-coc-highlight
+_extname=coc-highlight
+pkgdesc='Document highlight and document colors LSP support for coc.nvim'
+arch=('any')
+url='https://github.com/neoclide/coc-highlight'
+depends=('neovim-coc')
+makedepends=('git' 'yarn' 'npm')
+_packdir="usr/local/share/nvim/site/pack/coc/start/${_extname}"
+license=('')
+groups=('neovim-coc-extras-git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_extname}::git+${url}.git")
+pkgver=1.2.5.r2.gb4e82eb
+pkgrel=1
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_extname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_extname}"
+ yarn install --frozen-lockfile
+}
+
+package() {
+ cd "${srcdir}/${_extname}"
+ find lib/*.js package.json -type f -exec \
+ install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
+}