summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-07-28 09:00:05 +0800
committerSainnhepark2020-07-28 09:00:05 +0800
commitbe61ee95da78f0fe6a2d4ca4f5add0a8ad9825aa (patch)
tree045e3d8dc602cd6e05a6628eb5788f21e5521ca5
downloadaur-be61ee95da78f0fe6a2d4ca4f5add0a8ad9825aa.tar.gz
init
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..04edcacad39f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = neovim-coc-lists-git
+ pkgdesc = Common lists for coc.nvim
+ pkgver = 1.3.10.r0.gbf352d6
+ pkgrel = 1
+ url = https://github.com/neoclide/coc-lists
+ arch = any
+ groups = neovim-coc-extras-git
+ license =
+ makedepends = git
+ makedepends = yarn
+ makedepends = npm
+ depends = neovim-coc
+ provides = neovim-coc-lists
+ conflicts = neovim-coc-lists
+ source = coc-lists::git+https://github.com/neoclide/coc-lists.git
+ sha256sums = SKIP
+
+pkgname = neovim-coc-lists-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e4f2ee8543c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Sainnhe Park <sainnhe@gmail.com>
+pkgname=neovim-coc-lists-git
+_pkgname=neovim-coc-lists
+_extname=coc-lists
+pkgdesc='Common lists for coc.nvim'
+arch=('any')
+url='https://github.com/neoclide/coc-lists'
+depends=('neovim-coc')
+makedepends=('git' 'yarn' 'npm')
+_packdir="usr/local/share/nvim/site/pack/coc/start/${_extname}"
+license=('')
+groups=('neovim-coc-extras-git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_extname}::git+${url}.git")
+pkgver=1.3.10.r0.gbf352d6
+pkgrel=1
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_extname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_extname}"
+ yarn install --frozen-lockfile
+}
+
+package() {
+ cd "${srcdir}/${_extname}"
+ find lib/*.js nvimstart package.json -type f -exec \
+ install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
+}