summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-10-23 16:39:56 +0800
committerSainnhepark2020-10-23 16:39:56 +0800
commitca13d78c3a196a4e54f5fa1f728627f558bfe2c9 (patch)
tree4e323d18dbe77a902ba3c522f88da08b3d0c36d5
parent073ff90b20c0575257f9fe5b84ed9a4ed5875299 (diff)
downloadaur-ca13d78c3a196a4e54f5fa1f728627f558bfe2c9.tar.gz
add license
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04edcacad39f..089d0314278f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,7 @@ pkgbase = neovim-coc-lists-git
url = https://github.com/neoclide/coc-lists
arch = any
groups = neovim-coc-extras-git
- license =
+ license = MIT
makedepends = git
makedepends = yarn
makedepends = npm
diff --git a/PKGBUILD b/PKGBUILD
index c36d356eeaf5..b76470c09b45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ url='https://github.com/neoclide/coc-lists'
depends=('neovim-coc')
makedepends=('git' 'yarn' 'npm')
_packdir="usr/local/share/nvim/site/pack/coc/start/${_extname}"
-license=('')
+license=('MIT')
groups=('neovim-coc-extras-git')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
@@ -24,12 +24,12 @@ pkgver() {
build() {
cd "${srcdir}/${_extname}"
- yarn install --frozen-lockfile
+ yarn install --frozen-lockfile --preferred-cache-folder "${srcdir}/.cache/yarn"
yarn pack
tar xvf *.tgz
rm *.tgz
cd package
- npm install --only=production --no-lockfile --ignore-scripts
+ npm install --only=production --no-lockfile --ignore-scripts --cache "${srcdir}/.cache/npm"
}
package() {
@@ -37,4 +37,6 @@ package() {
find . -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
rm -rf "${srcdir}/${_extname}/package"
+ find "$pkgdir" -name package.json -print0 | xargs -r -0 sed -i '/_where/d'
+ chown -R root:root "${pkgdir}"
}