summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-10-23 16:44:48 +0800
committerSainnhepark2020-10-23 16:44:48 +0800
commita68bcc66513078d1377db8969d3ff2eda8b85799 (patch)
treecd94c835d381f9d0a2c7ff5cf3b83477a4a63893
parentc8f58be538dfad0731dfbbace06056332bffe487 (diff)
downloadaur-a68bcc66513078d1377db8969d3ff2eda8b85799.tar.gz
add license
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0d4818f608a..cab0d7b23980 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,7 @@ pkgbase = neovim-coc-pairs-git
url = https://github.com/neoclide/coc-pairs
arch = any
groups = neovim-coc-extras-git
- license =
+ license = MIT
makedepends = git
makedepends = yarn
makedepends = npm
diff --git a/PKGBUILD b/PKGBUILD
index 2f526eff592c..b69803c18847 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ url='https://github.com/neoclide/coc-pairs'
depends=('neovim-coc')
makedepends=('git' 'yarn' 'npm')
_packdir="usr/local/share/nvim/site/pack/coc/start/${_extname}"
-license=('')
+license=('MIT')
groups=('neovim-coc-extras-git')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
@@ -24,12 +24,12 @@ pkgver() {
build() {
cd "${srcdir}/${_extname}"
- yarn install --frozen-lockfile
+ yarn install --frozen-lockfile --preferred-cache-folder "${srcdir}/.cache/yarn"
yarn pack
tar xvf *.tgz
rm *.tgz
cd package
- npm install --only=production --no-lockfile --ignore-scripts
+ npm install --only=production --no-lockfile --ignore-scripts --cache "${srcdir}/.cache/npm"
}
package() {
@@ -37,4 +37,6 @@ package() {
find . -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
rm -rf "${srcdir}/${_extname}/package"
+ find "$pkgdir" -name package.json -print0 | xargs -r -0 sed -i '/_where/d'
+ chown -R root:root "${pkgdir}"
}