summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-11-06 21:36:05 +0800
committerSainnhepark2020-11-06 21:36:05 +0800
commite9efc1b08b2e5968975ed645fbbb57fb25bc2bef (patch)
treeb464d16b517f216a2f20fc6a9e3dd01c11c7d323
parenta873bfd937d8dd1313b8804dfa16ac68e64f7189 (diff)
downloadaur-e9efc1b08b2e5968975ed645fbbb57fb25bc2bef.tar.gz
add optdepends
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
2 files changed, 24 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5730e3aece3..738bd428feda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,6 +10,18 @@ pkgbase = neovim-coc-pyright-git
makedepends = git
depends = neovim-coc
depends = python
+ optdepends = autopep8: autopep8 formatting plugin
+ optdepends = python-black: black formatting plugin
+ optdepends = yapf: yapf formatting plugin
+ optdepends = flake8: flake8 linting plugin
+ optdepends = bandit: bandit linting plugin
+ optdepends = mypy: mypy linting plugin
+ optdepends = pytype: pytype linting plugin
+ optdepends = python-pep8: pep8 linting plugin
+ optdepends = python-prospector: prospector linting plugin
+ optdepends = python-pydocstyle: pydocstyle linting plugin
+ optdepends = pylama: pylama linting plugin
+ optdepends = python-pylint: pylint linting plugin
provides = neovim-coc-pyright
conflicts = neovim-coc-pyright
source = coc-pyright::git+https://github.com/fannheyward/coc-pyright.git
diff --git a/PKGBUILD b/PKGBUILD
index b447609ed4bb..15a10f7585cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,6 +10,18 @@ provides=("${_variant}-${_extname}")
conflicts=("${_variant}-${_extname}")
arch=('any')
depends=("${_variant}-coc" 'python')
+optdepends=('autopep8: autopep8 formatting plugin'
+ 'python-black: black formatting plugin'
+ 'yapf: yapf formatting plugin'
+ 'flake8: flake8 linting plugin'
+ 'bandit: bandit linting plugin'
+ 'mypy: mypy linting plugin'
+ 'pytype: pytype linting plugin'
+ 'python-pep8: pep8 linting plugin'
+ 'python-prospector: prospector linting plugin'
+ 'python-pydocstyle: pydocstyle linting plugin'
+ 'pylama: pylama linting plugin'
+ 'python-pylint: pylint linting plugin')
makedepends=('yarn' 'npm' 'git')
license=('MIT')
source=("${_extname}::git+${url}.git")