summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-10-23 16:52:24 +0800
committerSainnhepark2020-10-23 16:52:24 +0800
commit99f1dd21e8e5ca66038141a46215fb794e438569 (patch)
tree040810602ebca52d3e3944396e5f6e61322a514a
parentcdd36f408be638033a654e66a9d8a322fac6f417 (diff)
downloadaur-99f1dd21e8e5ca66038141a46215fb794e438569.tar.gz
add license
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f9deac65e935..125202402cf5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,7 @@ pkgbase = neovim-coc-rust-analyzer-git
pkgrel = 1
url = https://github.com/fannheyward/coc-rust-analyzer
arch = any
- license =
+ license = MIT
makedepends = yarn
makedepends = npm
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index 581174048f07..674d0b4f99d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ conflicts=("${_variant}-${_extname}")
arch=('any')
depends=("${_variant}-coc")
makedepends=('yarn' 'npm' 'git')
-license=('')
+license=('MIT')
source=("${_extname}::git+${url}.git")
pkgver=r464.4b3847f
pkgrel=1
@@ -24,12 +24,12 @@ pkgver() {
build() {
cd "${srcdir}/${_extname}"
- yarn install --frozen-lockfile
+ yarn install --frozen-lockfile --preferred-cache-folder "${srcdir}/.cache/yarn"
yarn pack
tar xvf *.tgz
rm *.tgz
cd package
- npm install --only=production --no-lockfile --ignore-scripts
+ npm install --only=production --no-lockfile --ignore-scripts --cache "${srcdir}/.cache/npm"
}
package() {
@@ -37,4 +37,6 @@ package() {
find . -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
rm -rf "${srcdir}/${_extname}/package"
+ find "$pkgdir" -name package.json -print0 | xargs -r -0 sed -i '/_where/d'
+ chown -R root:root "${pkgdir}"
}