summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-07-30 10:04:25 +0800
committerSainnhepark2020-07-30 10:04:25 +0800
commitcdd36f408be638033a654e66a9d8a322fac6f417 (patch)
treee0d89aa7d6c1ae593423ef527d8957b45a20d0b5
parentd1d1e17696dab2b6c5bfdad8e6079a3318e2d3b9 (diff)
downloadaur-cdd36f408be638033a654e66a9d8a322fac6f417.tar.gz
remove patch
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD15
-rw-r--r--serverPath.patch12
3 files changed, 3 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94b2fef0c0d9..f9deac65e935 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,13 +9,10 @@ pkgbase = neovim-coc-rust-analyzer-git
makedepends = npm
makedepends = git
depends = neovim-coc
- depends = rust-analyzer
provides = neovim-coc-rust-analyzer
conflicts = neovim-coc-rust-analyzer
source = coc-rust-analyzer::git+https://github.com/fannheyward/coc-rust-analyzer.git
- source = serverPath.patch
sha256sums = SKIP
- sha256sums = 88ba4cda5fb8729d653918a6d9d05161529ba21c7449e08a83507d47f8bcb64d
pkgname = neovim-coc-rust-analyzer-git
diff --git a/PKGBUILD b/PKGBUILD
index cf5c7c060682..581174048f07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,26 +9,19 @@ pkgname="${_variant}-${_extname}-git"
provides=("${_variant}-${_extname}")
conflicts=("${_variant}-${_extname}")
arch=('any')
-depends=("${_variant}-coc" 'rust-analyzer')
+depends=("${_variant}-coc")
makedepends=('yarn' 'npm' 'git')
license=('')
-source=("${_extname}::git+${url}.git"
- 'serverPath.patch')
+source=("${_extname}::git+${url}.git")
pkgver=r464.4b3847f
pkgrel=1
-sha256sums=('SKIP'
- '88ba4cda5fb8729d653918a6d9d05161529ba21c7449e08a83507d47f8bcb64d')
+sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${_extname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "${srcdir}/${_extname}"
- patch --forward --strip=1 --input="${srcdir}/serverPath.patch"
-}
-
build() {
cd "${srcdir}/${_extname}"
yarn install --frozen-lockfile
@@ -44,6 +37,4 @@ package() {
find . -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
rm -rf "${srcdir}/${_extname}/package"
- cd ../
- git checkout -- package.json
}
diff --git a/serverPath.patch b/serverPath.patch
deleted file mode 100644
index 2113042cbae0..000000000000
--- a/serverPath.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --unified --recursive --text coc-rust-analyzer/package.json coc-rust-analyzer-new/package.json
---- coc-rust-analyzer/package.json 2020-07-29 19:53:32.686164417 +0800
-+++ coc-rust-analyzer-new/package.json 2020-07-29 19:56:44.159484977 +0800
-@@ -281,7 +281,7 @@
- "null",
- "string"
- ],
-- "default": null,
-+ "default": "rust-analyzer",
- "description": "Path to rust-analyzer executable (points to bundled binary by default). If this is set, then \"rust-analyzer.updates.channel\" setting is not used"
- },
- "rust-analyzer.linkedProjects": {