summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-07-29 10:59:22 +0800
committerSainnhepark2020-07-29 10:59:22 +0800
commit7af6b514ffaac0165e916c2d8245489353013011 (patch)
tree4909f4aafeef0bfb3f1e1f1ef550324e6a3ff59e
downloadaur-7af6b514ffaac0165e916c2d8245489353013011.tar.gz
init
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD40
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ff01af068b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = neovim-coc-vimlsp-git
+ pkgdesc = VimL support for coc.nvim
+ pkgver = v0.8.0.r6.g0b7001d
+ pkgrel = 1
+ url = https://github.com/iamcco/coc-vimlsp
+ arch = any
+ license =
+ makedepends = yarn
+ makedepends = npm
+ depends = neovim-coc
+ depends = git
+ provides = neovim-coc-vimlsp
+ conflicts = neovim-coc-vimlsp
+ source = coc-vimlsp::git+https://github.com/iamcco/coc-vimlsp.git
+ sha256sums = SKIP
+
+pkgname = neovim-coc-vimlsp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9c4ccfe0ae1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Sainnhe Park <sainnhe@gmail.com>
+_variant='neovim'
+_extname=coc-vimlsp
+_packdir="usr/local/share/nvim/site/pack/coc/start/${_extname}"
+url='https://github.com/iamcco/coc-vimlsp'
+pkgdesc='VimL support for coc.nvim'
+
+pkgname="${_variant}-${_extname}-git"
+provides=("${_variant}-${_extname}")
+conflicts=("${_variant}-${_extname}")
+arch=('any')
+depends=("${_variant}-coc" 'git')
+makedepends=('yarn' 'npm')
+license=('')
+source=("${_extname}::git+${url}.git")
+pkgver=v0.8.0.r6.g0b7001d
+pkgrel=1
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_extname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_extname}"
+ yarn install --frozen-lockfile
+ yarn pack
+ tar xvf *.tgz
+ rm *.tgz
+ cd package
+ npm install --only=production --no-lockfile --ignore-scripts
+}
+
+package() {
+ cd "${srcdir}/${_extname}/package"
+ find . -type f -exec \
+ install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
+ rm -rf "${srcdir}/${_extname}/package"
+}