summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-10-23 17:09:27 +0800
committerSainnhepark2020-10-23 17:09:27 +0800
commit9e4ea1bad20c6ce66166ee5e0ce5206d17936378 (patch)
treef38c75ede1ea917fbcf0ee6e6b57ab0e79eb56f2
parent9bb5ec9e3ddf065f55d9c2f66f7d722025ae0714 (diff)
downloadaur-9e4ea1bad20c6ce66166ee5e0ce5206d17936378.tar.gz
add license
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e4683c58ca7..c03bc5e4c02f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,7 @@ pkgbase = neovim-coc-yaml-git
pkgrel = 1
url = https://github.com/neoclide/coc-yaml
arch = any
- license =
+ license = MIT
makedepends = yarn
makedepends = npm
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index 781ae577eaf4..e1ccd1d500dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ conflicts=("${_variant}-${_extname}")
arch=('any')
depends=("${_variant}-coc")
makedepends=('yarn' 'npm' 'git')
-license=('')
+license=('MIT')
source=("${_extname}::git+${url}.git")
pkgver=1.0.4.r1.ge3db99f
pkgrel=1
@@ -24,12 +24,12 @@ pkgver() {
build() {
cd "${srcdir}/${_extname}"
- yarn install --frozen-lockfile
+ yarn install --frozen-lockfile --preferred-cache-folder "${srcdir}/.cache/yarn"
yarn pack
tar xvf *.tgz
rm *.tgz
cd package
- npm install --only=production --no-lockfile --ignore-scripts
+ npm install --only=production --no-lockfile --ignore-scripts --cache "${srcdir}/.cache/npm"
}
package() {
@@ -37,4 +37,6 @@ package() {
find . -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
rm -rf "${srcdir}/${_extname}/package"
+ find "$pkgdir" -name package.json -print0 | xargs -r -0 sed -i '/_where/d'
+ chown -R root:root "${pkgdir}"
}