summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-07-29 18:54:58 +0800
committerSainnhepark2020-07-29 18:54:58 +0800
commitb162438dc4e40b9c6433ae84c3a2b7a3e8ccd2cf (patch)
tree915acedfe5f40ec3318764bed316df10bdb472a1
downloadaur-b162438dc4e40b9c6433ae84c3a2b7a3e8ccd2cf.tar.gz
init
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD40
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1cc46670b882
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = neovim-coc-yaml-git
+ pkgdesc = Yaml language server extension for coc.nvim
+ pkgver = 1.0.4.r1.ge3db99f
+ pkgrel = 1
+ url = https://github.com/neoclide/coc-yaml
+ arch = any
+ license =
+ makedepends = yarn
+ makedepends = npm
+ depends = neovim-coc
+ depends = git
+ provides = neovim-coc-yaml
+ conflicts = neovim-coc-yaml
+ source = coc-yaml::git+https://github.com/neoclide/coc-yaml.git
+ sha256sums = SKIP
+
+pkgname = neovim-coc-yaml-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..739209761205
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Sainnhe Park <sainnhe@gmail.com>
+_variant='neovim'
+_extname=coc-yaml
+_packdir="usr/local/share/nvim/site/pack/coc/start/${_extname}"
+url='https://github.com/neoclide/coc-yaml'
+pkgdesc='Yaml language server extension for coc.nvim'
+
+pkgname="${_variant}-${_extname}-git"
+provides=("${_variant}-${_extname}")
+conflicts=("${_variant}-${_extname}")
+arch=('any')
+depends=("${_variant}-coc" 'git')
+makedepends=('yarn' 'npm')
+license=('')
+source=("${_extname}::git+${url}.git")
+pkgver=1.0.4.r1.ge3db99f
+pkgrel=1
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_extname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_extname}"
+ yarn install --frozen-lockfile
+ yarn pack
+ tar xvf *.tgz
+ rm *.tgz
+ cd package
+ npm install --only=production --no-lockfile --ignore-scripts
+}
+
+package() {
+ cd "${srcdir}/${_extname}/package"
+ find . -type f -exec \
+ install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
+ rm -rf "${srcdir}/${_extname}/package"
+}