summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-07-28 16:32:31 +0800
committerSainnhepark2020-07-28 16:32:31 +0800
commitd8646a42c5f33cf56949a2e3e23d0d4d22db0420 (patch)
tree8c29fa880a15563f6447f7b55153aa8375daf0c3
parentb9556a6a5ff3ee0ff10da7302fa4ba388bdb809a (diff)
downloadaur-d8646a42c5f33cf56949a2e3e23d0d4d22db0420.tar.gz
update build()
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e0e82b540c7b..e7079c705610 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,10 +25,16 @@ pkgver() {
build() {
cd "${srcdir}/${_extname}"
yarn install --frozen-lockfile
+ yarn pack --frozen-lockfile --production
+ tar xvf *.tgz
+ rm *.tgz
+ cd package
+ yarn install --frozen-lockfile --production
}
package() {
- cd "${srcdir}/${_extname}"
- find lib/*.js package.json -type f -exec \
+ cd "${srcdir}/${_extname}/package"
+ find . -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
+ rm -rf "${srcdir}/${_extname}/package"
}