summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHezekiah Michael2019-05-29 16:51:56 -0400
committerHezekiah Michael2019-05-29 16:51:56 -0400
commitbd1cab9a7c4f5d98af82a78a78dcd6d1b2356956 (patch)
tree3dee064961bbce211e8d974862b94a3857663ffe
downloadaur-bd1cab9a7c4f5d98af82a78a78dcd6d1b2356956.tar.gz
Initial commit.
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..60d08beedd63
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = neovim-colors-brogrammer-git
+ pkgdesc = A dark, colorful syntax highlighting theme.
+ pkgver = 20190529
+ pkgrel = 1
+ url = https://github.com/ErikBoesen/vim-brogrammer-theme
+ arch = any
+ license = unknown
+ makedepends = git
+ depends = neovim
+ source = neovim-colors-brogrammer-git::git://github.com/ErikBoesen/vim-brogrammer-theme.git
+ sha256sums = SKIP
+
+pkgname = neovim-colors-brogrammer-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..aeb57057f86e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.xz
+neovim-colors-brogrammer-git
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65640601edaa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Hezekiah Michael < spiritomb at protonmail dot com>
+
+pkgname=neovim-colors-brogrammer-git
+pkgver=20190529
+pkgrel=1
+pkgdesc="A dark, colorful syntax highlighting theme."
+arch=('any')
+url="https://github.com/ErikBoesen/vim-brogrammer-theme"
+license=('unknown')
+makedepends=('git')
+depends=('neovim')
+source=("$pkgname::git://github.com/ErikBoesen/vim-brogrammer-theme.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ date +%Y%m%d
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -dm755 $pkgdir/usr/share/nvim/runtime/colors
+ install -Dm644 colors/* $pkgdir/usr/share/nvim/runtime/colors/
+}