summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-04-23 12:34:44 -0500
committerLuis Martinez2021-04-23 12:34:44 -0500
commitd9dd44227db338305f480957b1042de513ee9f45 (patch)
treefa5ed179b3d9dade88b9ba6613408b79a71dae9c
downloadaur-d9dd44227db338305f480957b1042de513ee9f45.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e1815a6db5a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = neovim-cursorline-git
+ pkgdesc = A Neovim plugin that highlights cursor words and lines
+ pkgver = r15.b6ad7dd
+ pkgrel = 1
+ url = https://github.com/yamatsum/nvim-cursorline
+ arch = any
+ groups = neovim-plugins
+ license = MIT
+ makedepends = git
+ depends = neovim
+ provides = neovim-cursorline
+ conflicts = neovim-cursorline
+ source = neovim-cursorline-git::git+https://github.com/yamatsum/nvim-cursorline
+ md5sums = SKIP
+
+pkgname = neovim-cursorline-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77918c47cc9c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+pkgname=neovim-cursorline-git
+pkgver=r15.b6ad7dd
+pkgrel=1
+pkgdesc="A Neovim plugin that highlights cursor words and lines"
+arch=('any')
+url="https://github.com/yamatsum/nvim-cursorline"
+license=('MIT')
+groups=('neovim-plugins')
+depends=('neovim')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ find lua plugin \
+ -type f -exec install Dvm 644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dvm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dvm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}