summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDamien Tardy-Panis2024-03-15 22:22:50 +0100
committerDamien Tardy-Panis2024-03-15 22:22:50 +0100
commitbc46914c802a7800ede57277b8cd8851e9828530 (patch)
treeec443e8bbffd49302e073c17e0e2a7d54a0f940b
parent19cb0ddc173aac6230680744d2e9d6691e47b20f (diff)
downloadaur-bc46914c802a7800ede57277b8cd8851e9828530.tar.gz
Cleanup build
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9881a92aedb5..3b875723acb3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,3 +11,4 @@ pkgbase = neovim-formatter-git
sha512sums = SKIP
pkgname = neovim-formatter-git
+ depends = neovim
diff --git a/PKGBUILD b/PKGBUILD
index 03488872ce49..c6d0cd0444a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,6 +13,7 @@ groups=(
makedepends=(
'git'
)
+
source=(
"git+https://github.com/mhartington/formatter.nvim.git"
)
@@ -27,7 +28,12 @@ pkgver() {
}
package() {
+ depends+=(
+ 'neovim'
+ )
+
cd formatter.nvim
find lua plugin doc -type f -exec install -D -m644 '{}' "$pkgdir/usr/share/nvim/site/pack/dist/start/${pkgname}/{}" \;
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
}