summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Walch2016-07-10 21:31:14 +0200
committerFlorian Walch2016-07-10 21:31:14 +0200
commit7e06c101d89e73e17ba5dc626d6452704f8fc673 (patch)
tree7eb43e029979ad611ae29dad0703c1b9880280f6
parent46fd0e05b1e1cc4fbc6e70c6343d1e18fcf86591 (diff)
downloadaur-7e06c101d89e73e17ba5dc626d6452704f8fc673.tar.gz
PKGBUILD: Add optional dependency on ruby-neovim.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD11
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e69f829da33f..c7377407396c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Apr 18 19:36:32 UTC 2016
+# Sun Jul 10 19:31:14 UTC 2016
pkgbase = neovim-git
pkgdesc = Fork of Vim aiming to improve user experience, plugins, and GUIs.
- pkgver = 0.1.3.r158.gba97f73
+ pkgver = 0.1.4.r610.g29060a5
pkgrel = 1
url = https://neovim.io
install = neovim-git.install
@@ -20,11 +20,12 @@ pkgbase = neovim-git
depends = libvterm
depends = msgpack-c
depends = unibilium
- optdepends = python2-neovim: for Python 2 plugin support (see :help nvim-python)
- optdepends = python-neovim: for Python 3 plugin support (see :help nvim-python)
- optdepends = xclip: for clipboard support (or xsel) (see :help nvim-clipboard)
- optdepends = xsel: for clipboard support (or xclip) (see :help nvim-clipboard)
- provides = neovim=0.1.3.r158.gba97f73
+ optdepends = python2-neovim: for Python 2 plugin support (see :help provider-python)
+ optdepends = python-neovim: for Python 3 plugin support (see :help provider-python)
+ optdepends = ruby-neovim: for Ruby plugin support (see :help provider-ruby)
+ optdepends = xclip: for clipboard support (or xsel) (see :help provider-clipboard)
+ optdepends = xsel: for clipboard support (or xclip) (see :help provider-clipboard)
+ provides = neovim=0.1.4.r610.g29060a5
conflicts = neovim
options = !strip
source = neovim-git::git+https://github.com/neovim/neovim.git
diff --git a/PKGBUILD b/PKGBUILD
index 35a73f987fe4..a936c474cf02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Florian Hahn <flo@fhahn.com>
pkgname=neovim-git
-pkgver=0.1.3.r158.gba97f73
+pkgver=0.1.4.r610.g29060a5
pkgrel=1
pkgdesc='Fork of Vim aiming to improve user experience, plugins, and GUIs.'
arch=('i686' 'x86_64')
@@ -10,10 +10,11 @@ url='https://neovim.io'
license=('custom:neovim')
depends=('jemalloc' 'libtermkey' 'libuv' 'libvterm' 'msgpack-c' 'unibilium')
makedepends=('cmake' 'git' 'luajit' 'lua51-mpack' 'lua51-lpeg')
-optdepends=('python2-neovim: for Python 2 plugin support (see :help nvim-python)'
- 'python-neovim: for Python 3 plugin support (see :help nvim-python)'
- 'xclip: for clipboard support (or xsel) (see :help nvim-clipboard)'
- 'xsel: for clipboard support (or xclip) (see :help nvim-clipboard)')
+optdepends=('python2-neovim: for Python 2 plugin support (see :help provider-python)'
+ 'python-neovim: for Python 3 plugin support (see :help provider-python)'
+ 'ruby-neovim: for Ruby plugin support (see :help provider-ruby)'
+ 'xclip: for clipboard support (or xsel) (see :help provider-clipboard)'
+ 'xsel: for clipboard support (or xclip) (see :help provider-clipboard)')
source=("${pkgname}::git+https://github.com/neovim/neovim.git")
sha256sums=('SKIP')
provides=("neovim=${pkgver}")