summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchetgurevitch2017-08-06 19:03:47 -0700
committerchetgurevitch2017-08-06 19:03:47 -0700
commit304554a63b23e8907c1c0c5d159d13d2cd79da04 (patch)
tree7a61ca2dca9f1bf9161612a590afcf89ae6abfe0
downloadaur-304554a63b23e8907c1c0c5d159d13d2cd79da04.tar.gz
Initial commit
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD55
-rw-r--r--neovim-git-ninja.install16
3 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c6b9d399712c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = neovim-git-ninja
+ pkgdesc = Fork of Vim aiming to improve user experience, plugins, and GUIs
+ pkgver = 0.2.0.r660.g2753d61e4
+ pkgrel = 1
+ url = https://neovim.io
+ install = neovim-git-ninja.install
+ arch = i686
+ arch = x86_64
+ license = custom:neovim
+ makedepends = cmake
+ makedepends = git
+ makedepends = gperf
+ makedepends = lua51-lpeg
+ makedepends = lua51-mpack
+ makedepends = ninja
+ depends = jemalloc
+ depends = libtermkey
+ depends = libuv
+ depends = libvterm
+ depends = luajit
+ depends = msgpack-c
+ depends = unibilium
+ optdepends = python2-neovim: for Python 2 plugin support (see :help provider-python)
+ optdepends = python-neovim: for Python 3 plugin support (see :help provider-python)
+ optdepends = ruby-neovim: for Ruby plugin support (see :help provider-ruby)
+ optdepends = xclip: for clipboard support (or xsel) (see :help provider-clipboard)
+ optdepends = xsel: for clipboard support (or xclip) (see :help provider-clipboard)
+ provides = neovim=0.2.0.r660.g2753d61e4
+ conflicts = neovim
+ options = !strip
+ source = neovim-git-ninja::git+https://github.com/neovim/neovim.git
+ sha256sums = SKIP
+
+pkgname = neovim-git-ninja
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..330fb6fa07e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: chet <chetgurevitch @ protonmail . com>
+# Contributor: Florian Walch <florian+aur @ fwalch . com>
+# Contributor: Sven-Hendrik Haase <sh @ lutzhaase . com>
+# Contributor: Florian Hahn <flo @ fhahn . com>
+
+pkgname=neovim-git-ninja
+pkgver=0.2.0.r660.g2753d61e4
+pkgrel=1
+pkgdesc='Fork of Vim aiming to improve user experience, plugins, and GUIs'
+arch=('i686' 'x86_64')
+url='https://neovim.io'
+license=('custom:neovim')
+depends=('jemalloc' 'libtermkey' 'libuv' 'libvterm' 'luajit' 'msgpack-c' 'unibilium')
+makedepends=('cmake' 'git' 'gperf' 'lua51-lpeg' 'lua51-mpack' 'ninja')
+optdepends=('python2-neovim: for Python 2 plugin support (see :help provider-python)'
+ 'python-neovim: for Python 3 plugin support (see :help provider-python)'
+ 'ruby-neovim: for Ruby plugin support (see :help provider-ruby)'
+ 'xclip: for clipboard support (or xsel) (see :help provider-clipboard)'
+ 'xsel: for clipboard support (or xclip) (see :help provider-clipboard)')
+source=("${pkgname}::git+https://github.com/neovim/neovim.git")
+sha256sums=('SKIP')
+install="${pkgname}.install"
+
+provides=("neovim=${pkgver}")
+conflicts=('neovim')
+options=(!strip)
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long | sed 's/^v//;s/-/.r/;s/-/./'
+}
+
+build() {
+ mkdir -p "${pkgname}/build"
+ cd "${pkgname}/build"
+
+ rm -rf runtime/doc
+ cmake -G 'Ninja' \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ ..
+ ninja
+}
+
+check() {
+ cd "${pkgname}/build/bin"
+ ./nvim --version
+ ./nvim --headless -u NONE -i NONE -c ':quit'
+}
+
+package() {
+ cd "${pkgname}"
+ DESTDIR="${pkgdir}" ninja -C build install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/neovim-git-ninja.install b/neovim-git-ninja.install
new file mode 100644
index 000000000000..fac9b3ab6018
--- /dev/null
+++ b/neovim-git-ninja.install
@@ -0,0 +1,16 @@
+# arg 1: the new package version
+post_install() {
+ echo ":: The Neovim executable is called 'nvim'."
+ echo ":: If you are already familiar with Vim, see ':help nvim-from-vim'"
+ echo " to get started."
+ echo ":: If you have any questions, check the following page first:"
+ echo " https://github.com/neovim/neovim/wiki/FAQ"
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ echo ":: Check the following page to see whether this upgrade"
+ echo " includes any breaking changes:"
+ echo " https://github.com/neovim/neovim/wiki/Following-HEAD"
+}