summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlisk2017-10-09 06:46:51 +0200
committerFlisk2017-10-09 06:51:35 +0200
commit433e813f8e267d571817482422ec40b507ebbb91 (patch)
tree29b9a2500b534157318a91aa66d9bf3e416370d6
parent9a264ba4194e6e605a381c3ac8111945b7ddc345 (diff)
downloadaur-433e813f8e267d571817482422ec40b507ebbb91.tar.gz
Adapt PKGBUILD from neovim-gtk-git
Let's hope the author got the dependencies right.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD42
2 files changed, 30 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 077160eb884a..0f579f9141e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = neovim-gtk
- pkgdesc = GTK ui for neovim written in rust using gtk-rs bindings. With ligatures support.
+ pkgdesc = GTK UI for Neovim written in Rust
pkgver = v0.1.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/daa84/neovim-gtk
- arch = x86_64
arch = i686
+ arch = x86_64
license = GPL3
makedepends = rust
makedepends = cargo
makedepends = git
+ depends = neovim
depends = gtk3
- source = neovim-gtk::git+https://github.com/daa84/neovim-gtk.git
- sha256sums = SKIP
+ depends = vte3
+ source = git+https://github.com/daa84/neovim-gtk.git
+ md5sums = SKIP
pkgname = neovim-gtk
diff --git a/PKGBUILD b/PKGBUILD
index 1c0d84e49659..629d855950a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,31 @@
-pkgname="neovim-gtk"
-_pkgname="neovim-gtk"
-pkgdesc="GTK ui for neovim written in rust using gtk-rs bindings. With ligatures support."
+# Maintainer: Tobias Umbach <tobias@fastmail.mx>
+# PKGBUILD author: Wesley Moore <wes@wezm.net>
+pkgname=neovim-gtk
+_pkgname=neovim-gtk
pkgver=v0.1.1
-pkgrel=1
-depends=('gtk3')
-arch=('x86_64' 'i686')
+pkgrel=2
+pkgdesc='GTK UI for Neovim written in Rust'
+arch=('i686' 'x86_64')
url="https://github.com/daa84/neovim-gtk"
license=('GPL3')
+depends=('neovim' 'gtk3' 'vte3')
makedepends=('rust' 'cargo' 'git')
-source=("$_pkgname::git+https://github.com/daa84/neovim-gtk.git")
-sha256sums=('SKIP')
+source=("git+https://github.com/daa84/neovim-gtk.git")
+md5sums=('SKIP')
-package() {
- cd "$_pkgname"
-
- env CARGO_INCREMENTAL=0 cargo build --release
-
- install -D -m755 "$srcdir/$_pkgname/target/release/nvim-gtk" \
- "$pkgdir/usr/bin/nvim-gtk"
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git rev-list --count HEAD
+}
- install -D -m755 "$srcdir/$_pkgname/desktop/org.daa.NeovimGtk.desktop" \
- "$pkgdir/usr/share/applications/org.daa.NeovimGtk.desktop"
+build() {
+ cd "$srcdir/$_pkgname"
+ cargo build --release
+}
- install -D -m755 "$srcdir/$_pkgname/desktop/org.daa.NeovimGtk.png" \
- "$pkgdir/usr/share/pixmaps/org.daa.NeovimGtk.png"
+package() {
+ install -Dm755 "$srcdir/$_pkgname/target/release/nvim-gtk" "$pkgdir/usr/bin/nvim-gtk"
+ install -D -m644 "$srcdir/$_pkgname/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 "$srcdir/$_pkgname/desktop/org.daa.NeovimGtk.desktop" "${pkgdir}"/usr/share/applications/org.daa.NeovimGtk.desktop
+ install -D -m644 "$srcdir/$_pkgname/desktop/org.daa.NeovimGtk.png" "${pkgdir}"/usr/share/pixmaps/org.daa.NeovimGtk.png
}