summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-07-20 16:18:24 -0500
committerLuis Martinez2022-07-20 16:18:24 -0500
commit24ecb99193a610a7cabbadf29c60532f7d56fcb5 (patch)
treef3dc860264b41c06eb2a60c444c3f2f927c52e00
downloadaur-24ecb99193a610a7cabbadf29c60532f7d56fcb5.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
-rw-r--r--highlight-colors.install9
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..353317216371
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = neovim-highlight-colors-git
+ pkgdesc = Highlight color codes in Neovim
+ pkgver = r26.30be040
+ pkgrel = 1
+ url = https://github.com/brenoprata10/nvim-highlight-colors
+ install = highlight-colors.install
+ arch = any
+ groups = neovim-plugins
+ license = unknown
+ makedepends = git
+ depends = neovim
+ provides = neovim-highlight-colors
+ conflicts = neovim-highlight-colors
+ source = neovim-highlight-colors::git+https://github.com/brenoprata10/nvim-highlight-colors
+ sha256sums = SKIP
+
+pkgname = neovim-highlight-colors-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..193490c1fa55
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=neovim-highlight-colors-git
+_pkgname="${pkgname%-git}"
+pkgver=r26.30be040
+pkgrel=1
+pkgdesc="Highlight color codes in Neovim"
+arch=('any')
+url="https://github.com/brenoprata10/nvim-highlight-colors"
+license=('unknown')
+groups=('neovim-plugins')
+depends=('neovim')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+install=highlight-colors.install
+source=("$_pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" )
+}
+
+package() {
+ cd "$_pkgname"
+ find lua plugin -type f -exec install -Dm644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
diff --git a/highlight-colors.install b/highlight-colors.install
new file mode 100644
index 000000000000..5c32e582cf0a
--- /dev/null
+++ b/highlight-colors.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo ':: This plugin requires manual setup.'
+ echo ':: Consult upstream documentation for more information.'
+ echo ':: A copy has been installed under /usr/share/doc/neovim-highlight-colors-git/README.md for your reference.'
+}
+
+post_remove() {
+ echo ':: Remember to remove all references to this plugin from your init scripts.'
+}