summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-08-22 18:51:49 -0500
committerLuis Martinez2021-08-22 18:51:49 -0500
commit3410898e8262d1d1989875f1b69683b5efbfbb43 (patch)
tree43e9e0be723ebba2cf53935b150d6f9e3f06ffe6
downloadaur-3410898e8262d1d1989875f1b69683b5efbfbb43.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
-rw-r--r--hop.install8
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6c9741e67c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = neovim-hop-git
+ pkgdesc = A plugin that lets you jump anywhere in a document with as few keystrokes as possible
+ pkgver = r153.9c849da
+ pkgrel = 1
+ url = https://github.com/phaazon/hop.nvim
+ install = hop.install
+ arch = any
+ groups = neovim-plugins
+ license = BSD
+ makedepends = git
+ depends = neovim
+ provides = neovim-hop
+ conflicts = neovim-hop
+ source = neovim-hop-git::git+https://github.com/phaazon/hop.nvim
+ md5sums = SKIP
+
+pkgname = neovim-hop-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43d98a359e03
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=neovim-hop-git
+pkgver=r153.9c849da
+pkgrel=1
+pkgdesc="A plugin that lets you jump anywhere in a document with as few keystrokes as possible"
+arch=('any')
+url="https://github.com/phaazon/hop.nvim"
+license=('BSD')
+groups=('neovim-plugins')
+depends=('neovim')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install=hop.install
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ find doc lua plugin -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
diff --git a/hop.install b/hop.install
new file mode 100644
index 000000000000..661532471386
--- /dev/null
+++ b/hop.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo ':: Please consult upstream documentation for information on how to set up this plugin.'
+ echo ':: A copy has been installed for your reference under /usr/share/doc/neovim-hop-git/README.md'
+}
+
+post_remove() {
+ echo ":: Don't forget to remove all references to this plugin from your init scripts."
+}