summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Konovalov2021-12-24 12:28:34 +0500
committerIvan Konovalov2021-12-24 12:28:34 +0500
commit596e90af32f87d816e8fa5cecf17c74b8df50664 (patch)
tree88f5e23dd1038ed71704913b62b5d861df837891
downloadaur-596e90af32f87d816e8fa5cecf17c74b8df50664.tar.gz
Initial commit
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD24
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4dfca7ae48b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = neovim-hybrid
+ pkgdesc = A dark color scheme for Neovim
+ pkgver = r46.cc58baa
+ pkgrel = 1
+ arch = any
+ groups = neovim-plugins
+ license = MIT
+ source = https://github.com/w0ng/vim-hybrid/archive/cc58baabeabc7b83768e25b852bf89c34756bf90.zip
+ sha256sums = 50b496f0a2e94b2d05066344ba08af60d490aa4ce9edc9976c90ccd6796d63c3
+
+pkgname = neovim-hybrid
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d83159bb04a0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+.*.sw[a-z]
+.sw[a-z]
+*.py[co]
+*.tar.xz
+*.tar.gz
+*.tar.zst
+*.zip
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd5a01fb9928
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Ivan Konovalov <ivknv0@gmail.com>
+
+pkgname=neovim-hybrid
+_commit=cc58baabeabc7b83768e25b852bf89c34756bf90
+arch=('any')
+license=('MIT')
+makedepends=()
+groups=('neovim-plugins')
+pkgver=r46.cc58baa
+pkgrel=1
+pkgdesc='A dark color scheme for Neovim'
+source=("https://github.com/w0ng/vim-hybrid/archive/$_commit.zip")
+sha256sums=('50b496f0a2e94b2d05066344ba08af60d490aa4ce9edc9976c90ccd6796d63c3')
+
+prepare() {
+ cd "vim-hybrid-$_commit"
+ tail -24 colors/hybrid.vim | head -23 | cut -b3- > LICENSE
+}
+
+package() {
+ cd "vim-hybrid-$_commit"
+ install -Dvm644 colors/hybrid.vim "$pkgdir/usr/share/nvim/runtime/colors/hybrid.vim"
+ install -Dvm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}