summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMasoud Naservand2016-02-06 11:46:28 +0330
committerMasoud Naservand2016-02-06 11:46:28 +0330
commitd3b051f65bf82ca006afb74c58a6d8f3af26854b (patch)
treeb6ee194a4e16cdf7fb306f0afd9204e1fafb27cf
downloadaur-d3b051f65bf82ca006afb74c58a6d8f3af26854b.tar.gz
Changed the vim-jellybeans package for neovim
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..899a72f87aab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sat Feb 6 08:13:48 UTC 2016
+pkgbase = neovim-jellybeans
+ pkgdesc = Colorful, dark color scheme, inspired by ir_black and twilight
+ pkgver = 1.5
+ pkgrel = 1
+ url = https://github.com/nanotech/jellybeans.vim
+ arch = any
+ groups = neovim-plugins
+ license = MIT
+ depends = neovim
+ source = https://github.com/nanotech/jellybeans.vim/archive/v1.5.zip
+ sha256sums = f4399b3230ca52b966e1a99370b38420dd2b0db02dac8c8606b43b00850603ed
+
+pkgname = neovim-jellybeans
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b752fed0935
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Masoud Naservand <relive.mn@gmail.com>
+# Contributor: Alexander Rødseth <rodseth@gmail.com>
+
+
+pkgname='neovim-jellybeans'
+_name=jellybeans.vim
+pkgver=1.5
+pkgrel=1
+pkgdesc='Colorful, dark color scheme, inspired by ir_black and twilight'
+arch=('any')
+url="https://github.com/nanotech/$_name"
+license=('MIT')
+groups=('neovim-plugins')
+depends=('neovim')
+source=("https://github.com/nanotech/$_name/archive/v$pkgver.zip")
+sha256sums=('f4399b3230ca52b966e1a99370b38420dd2b0db02dac8c8606b43b00850603ed')
+
+prepare() {
+ head -41 "$_name-$pkgver/colors/$_name" | tail -21 | cut -b2- > LICENSE
+}
+
+package() {
+ install -Dm644 "$_name-$pkgver/colors/$_name" \
+ "$pkgdir/usr/share/nvim/runtime/colors/$_name"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: