summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShane Stone2020-04-29 18:18:51 -0700
committerShane Stone2020-04-29 18:18:51 -0700
commit0c9a7db73a0ae94445d032f7ce22ad5732b2d44f (patch)
tree6e14852916c986eb4cfed172e75d170159c90455
parent2bb75c4ff833d42526093cc3c38b22dae06214d4 (diff)
downloadaur-0c9a7db73a0ae94445d032f7ce22ad5732b2d44f.tar.gz
Simplify PKGBUILD
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23e6fadba4df..42a249c2f40a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,7 @@ pkgbase = neovim-lion-opt-git
license = custom:vim
makedepends = git
depends = neovim
- source = git+https://github.com/tommcdo/vim-lion.git
+ source = lion::git+https://github.com/tommcdo/vim-lion.git
sha256sums = SKIP
pkgname = neovim-lion-opt-git
diff --git a/PKGBUILD b/PKGBUILD
index 65ec08ea2520..3a4bad10ba8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,13 +8,13 @@ url="https://github.com/tommcdo/vim-${_pkgname}"
license=('custom:vim')
depends=('neovim')
makedepends=('git')
-source=("git+${url}.git")
+source=("${_pkgname}::git+${url}.git")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/vim-${_pkgname}"
+ cd "${srcdir}/${_pkgname}"
echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
@@ -22,7 +22,7 @@ pkgver() {
package() {
- cd "${srcdir}/vim-${_pkgname}"
+ cd "${srcdir}/${_pkgname}"
local _installpath="usr/local/share/nvim/site/pack/${_pkgname}/opt/${_pkgname}/"