summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShane Stone2019-04-19 21:50:31 -0700
committerShane Stone2019-04-19 21:50:31 -0700
commit2bb75c4ff833d42526093cc3c38b22dae06214d4 (patch)
tree9a454aaebf8b23aba78cbee316b12a0fc9d47abe
downloadaur-2bb75c4ff833d42526093cc3c38b22dae06214d4.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..23e6fadba4df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = neovim-lion-opt-git
+ pkgdesc = A simple alignment operator for (neo)vim.
+ pkgver = 56.75306ac
+ pkgrel = 1
+ url = https://github.com/tommcdo/vim-lion
+ arch = any
+ license = custom:vim
+ makedepends = git
+ depends = neovim
+ source = git+https://github.com/tommcdo/vim-lion.git
+ sha256sums = SKIP
+
+pkgname = neovim-lion-opt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65ec08ea2520
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname=neovim-lion-opt-git
+pkgver=56.75306ac
+_pkgname=lion
+pkgrel=1
+pkgdesc='A simple alignment operator for (neo)vim.'
+arch=('any')
+url="https://github.com/tommcdo/vim-${_pkgname}"
+license=('custom:vim')
+depends=('neovim')
+makedepends=('git')
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+
+ cd "${srcdir}/vim-${_pkgname}"
+
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+
+}
+
+package() {
+
+ cd "${srcdir}/vim-${_pkgname}"
+
+ local _installpath="usr/local/share/nvim/site/pack/${_pkgname}/opt/${_pkgname}/"
+
+ install -dvm755 "${pkgdir}/${_installpath}"
+
+ cp -rvt "${pkgdir}/${_installpath}" doc plugin
+
+}