summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-01-04 23:17:12 -0600
committerLuis Martinez2022-01-04 23:17:12 -0600
commit722c269cc6c1d98aba88c2807265c156911701e0 (patch)
tree1268a2988be6187148c5900f18a3d090989ae1cd
parent1b6414b8d4cee2e223208880fa571f7350cc2e08 (diff)
downloadaur-722c269cc6c1d98aba88c2807265c156911701e0.tar.gz
first tagged release
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD35
-rw-r--r--lspconfig.install9
3 files changed, 33 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61c3dbb1394f..180bf97d726d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = neovim-lspconfig
- pkgdesc = Quickstart configurations for the Nvim LSP client.
- pkgver = 9661d26
+ pkgdesc = Quickstart configurations for the Neovim LSP client
+ pkgver = 0.1.0
pkgrel = 1
url = https://github.com/neovim/nvim-lspconfig
+ install = lspconfig.install
arch = any
groups = neovim-plugins
license = Apache
- makedepends = git
depends = neovim
- depends = lua
- optdepends = neovim-plug: for plugin manager
- source = git+https://github.com/neovim/nvim-lspconfig
- sha256sums = SKIP
+ source = neovim-lspconfig-0.1.0.tar.gz::https://github.com/neovim/nvim-lspconfig/archive/v0.1.0.tar.gz
+ sha256sums = e4c0719c2bf13a3842deb10af3136c64903466bbbc3df9af1ef3e338b8898aae
pkgname = neovim-lspconfig
diff --git a/PKGBUILD b/PKGBUILD
index 57ae5dc0019d..dfc0b721f100 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,26 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
pkgname=neovim-lspconfig
-pkgver=9661d26
+pkgver=0.1.0
pkgrel=1
-pkgdesc='Quickstart configurations for the Nvim LSP client.'
+pkgdesc='Quickstart configurations for the Neovim LSP client'
arch=('any')
url=https://github.com/neovim/nvim-lspconfig
license=('Apache')
groups=('neovim-plugins')
-depends=('neovim' 'lua')
-makedepends=('git')
-optdepends=('neovim-plug: for plugin manager')
-source=("git+${url}")
-sha256sums=('SKIP')
-package(){
- cd "${srcdir}/nvim-lspconfig"
- mkdir -p "${pkgdir}/usr/share/nvim/runtime"
- install -Dm644 "plugin/lspconfig.vim" "${pkgdir}/usr/share/nvim/runtime/plugin/lspconfig.vim"
- cp -a lua "${pkgdir}/usr/share/nvim/runtime/"
-}
-pkgver(){
- cd "${srcdir}/nvim-lspconfig"
- git rev-parse --short HEAD
+depends=('neovim')
+install=lspconfig.install
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('e4c0719c2bf13a3842deb10af3136c64903466bbbc3df9af1ef3e338b8898aae')
+
+PURGE_TARGETS=('tags')
+
+package() {
+ cd "nvim-lspconfig-$pkgver"
+ find autoload lua plugin \
+ -type f \
+ -exec install -Dm644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dm644 doc/lspconfig.txt -t "$pkgdir/usr/share/nvim/runtime/doc/"
+ install -Dm644 README.md doc/server_configurations.md \
+ -t "$pkgdir/usr/share/doc/$pkgname/"
}
diff --git a/lspconfig.install b/lspconfig.install
new file mode 100644
index 000000000000..f6b257d44684
--- /dev/null
+++ b/lspconfig.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo ':: This plugin requires manual setup.'
+ echo ':: Consult upstream documentation for more information.'
+ echo ':: A copy has been installed under /usr/share/doc/neovim-lspconfig/README.md for your reference.'
+}
+
+post_remove() {
+ echo ':: Remember to remove all references to this plugin from your init scripts.'
+}