summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhanghua0002021-10-11 20:09:32 +0800
committerzhanghua0002021-10-11 20:09:32 +0800
commit754b8ccfb8076f20ad5e31d61a5da0882c4ff8e8 (patch)
treef67e5e5f6fa20f5bb93fa0763cff166ffe10ddad
downloadaur-754b8ccfb8076f20ad5e31d61a5da0882c4ff8e8.tar.gz
First Release
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6115b8ca4f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = neovim-lspconfig
+ pkgdesc = Quickstart configurations for the Nvim LSP client.
+ pkgver = e609a70
+ pkgrel = 1
+ url = https://github.com/neovim/nvim-lspconfig
+ arch = any
+ groups = neovim-plugins
+ license = Apache
+ makedepends = git
+ depends = neovim
+ depends = neovim-plug
+ depends = lua
+ source = git+https://github.com/neovim/nvim-lspconfig
+ sha256sums = SKIP
+
+pkgname = neovim-lspconfig
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..42c97330ebc5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.pkg.tar.zst
+nvim-lspconfig
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c110ed14dc6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=neovim-lspconfig
+pkgver=e609a70
+pkgrel=1
+pkgdesc='Quickstart configurations for the Nvim LSP client.'
+arch=('any')
+url=https://github.com/neovim/nvim-lspconfig
+license=('Apache')
+groups=('neovim-plugins')
+depends=('neovim' 'neovim-plug' 'lua')
+makedepends=('git')
+source=("git+${url}")
+sha256sums=('SKIP')
+_luajitver=2.0.5
+package(){
+ cd "${srcdir}/nvim-lspconfig"
+ install -Dm644 "plugin/lspconfig.vim" "${pkgdir}/usr/share/nvim/runtime/plugin/lspconfig.vim"
+ mkdir -p "${pkgdir}/usr/share/luajit-${_luajitver}"
+ cp -a lua/* "${pkgdir}/usr/share/luajit-${_luajitver}/"
+}
+pkgver(){
+ cd "${srcdir}/nvim-lspconfig"
+ git rev-parse --short HEAD
+}