summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-10-14 03:10:19 -0500
committerLuis Martinez2021-10-14 03:10:19 -0500
commit038b0e06494346b2be9f26ea6881eb8a9e2c657c (patch)
treefd083089c6499add77471778f581285484c0a904
downloadaur-038b0e06494346b2be9f26ea6881eb8a9e2c657c.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
-rw-r--r--luasnip.install9
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2dd0d30b0c6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = neovim-luasnip-git
+ pkgdesc = Snippet engine for Neovim
+ pkgver = r829.4526e71
+ pkgrel = 1
+ url = https://github.com/L3MON4D3/LuaSnip
+ install = luasnip.install
+ arch = any
+ groups = neovim-plugin
+ license = Apache
+ makedepends = git
+ depends = neovim>=0.5
+ provides = neovim-luasnip
+ conflicts = neovim-luasnip
+ source = neovim-luasnip-git::git+https://github.com/L3MON4D3/LuaSnip
+ md5sums = SKIP
+
+pkgname = neovim-luasnip-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fed01960d69b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=neovim-luasnip-git
+pkgver=r829.4526e71
+pkgrel=1
+pkgdesc="Snippet engine for Neovim"
+arch=('any')
+url="https://github.com/L3MON4D3/LuaSnip"
+license=('Apache')
+groups=('neovim-plugin')
+depends=('neovim>=0.5')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install=luasnip.install
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ find doc lua plugin -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
diff --git a/luasnip.install b/luasnip.install
new file mode 100644
index 000000000000..b4151779bed5
--- /dev/null
+++ b/luasnip.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo ':: This plugin requires manual setup.'
+ echo ':: Consult upstream documentation for more information.'
+ echo ':: A copy has been installed under /usr/share/doc/neovim-luasnip-git/README.md for your reference.'
+}
+
+post_remove() {
+ echo ':: Remember to remove all references to this plugin from your init scripts.'
+}