summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDamien Tardy-Panis2024-03-15 22:23:03 +0100
committerDamien Tardy-Panis2024-03-15 22:23:03 +0100
commit1be04ac76747a4558cec9ae24bbb1b6ef96f6444 (patch)
tree9307f40e0ddcccb62d511bb74e0a4520a651bb8d
parent179fe13c79444204237543fad92a25ae881f2f2b (diff)
downloadaur-1be04ac76747a4558cec9ae24bbb1b6ef96f6444.tar.gz
Cleanup build
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD43
-rw-r--r--luasnip.install9
3 files changed, 32 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 492e24dbfbe8..2a50cace52c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
pkgbase = neovim-luasnip-git
pkgdesc = Snippet engine for Neovim
- pkgver = 1.2.1.r30.gd33cf7d
+ pkgver = 2.2.0.r25.ga7a4b46
pkgrel = 1
url = https://github.com/L3MON4D3/LuaSnip
- install = luasnip.install
arch = any
- groups = neovim-plugin
+ groups = neovim-plugins
license = Apache
makedepends = git
- depends = neovim
- provides = neovim-luasnip
- conflicts = neovim-luasnip
- source = neovim-luasnip-git::git+https://github.com/L3MON4D3/LuaSnip
- md5sums = SKIP
+ source = git+https://github.com/L3MON4D3/LuaSnip.git
+ sha512sums = SKIP
pkgname = neovim-luasnip-git
+ depends = neovim
diff --git a/PKGBUILD b/PKGBUILD
index 2f7c2876b9b5..0be62735ae32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,39 @@
-# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
-
pkgname=neovim-luasnip-git
-pkgver=1.2.1.r30.gd33cf7d
+pkgver=2.2.0.r25.ga7a4b46
pkgrel=1
pkgdesc="Snippet engine for Neovim"
arch=('any')
url="https://github.com/L3MON4D3/LuaSnip"
license=('Apache')
-groups=('neovim-plugin')
-depends=('neovim')
-makedepends=('git')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-install=luasnip.install
-source=("$pkgname::git+$url")
-md5sums=('SKIP')
+
+groups=(
+ 'neovim-plugins'
+)
+
+makedepends=(
+ 'git'
+)
+
+source=(
+ "git+https://github.com/L3MON4D3/LuaSnip.git"
+)
+
+sha512sums=(
+ 'SKIP'
+)
pkgver() {
- git -C "$pkgname" describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+ cd LuaSnip
+ git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
}
package() {
- local dirs=(doc ftplugin lua plugin syntax)
- cd "$pkgname"
- find "${dirs[@]}" -type f -exec install -Dvm644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
- install -Dvm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+ depends+=(
+ 'neovim'
+ )
+
+ cd LuaSnip
+ find doc ftplugin lua plugin syntax -type f -exec install -D -m644 '{}' "$pkgdir/usr/share/nvim/site/pack/dist/start/${pkgname}/{}" \;
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
}
diff --git a/luasnip.install b/luasnip.install
deleted file mode 100644
index b4151779bed5..000000000000
--- a/luasnip.install
+++ /dev/null
@@ -1,9 +0,0 @@
-post_install() {
- echo ':: This plugin requires manual setup.'
- echo ':: Consult upstream documentation for more information.'
- echo ':: A copy has been installed under /usr/share/doc/neovim-luasnip-git/README.md for your reference.'
-}
-
-post_remove() {
- echo ':: Remember to remove all references to this plugin from your init scripts.'
-}