summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-09-03 22:42:33 -0500
committerLuis Martinez2022-09-03 22:42:33 -0500
commit919da2203640d92992963fef6097d57cdd355629 (patch)
tree1ccb4188d9003976ecfd42016bb95492a2813348
downloadaur-919da2203640d92992963fef6097d57cdd355629.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
-rw-r--r--matchparen.install9
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..545b4f922bf1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = neovim-matchparen-git
+ pkgdesc = Alternative neovim matchparen plugin
+ pkgver = r137.6860f53
+ pkgrel = 1
+ url = https://github.com/monkoose/matchparen.nvim
+ install = matchparen.install
+ arch = any
+ groups = neovim-plugins
+ license = MIT
+ makedepends = git
+ depends = neovim
+ provides = neovim-matchparen
+ conflicts = neovim-matchparen
+ source = neovim-matchparen::git+https://github.com/monkoose/matchparen.nvim
+ sha256sums = SKIP
+
+pkgname = neovim-matchparen-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e5e637a3b5e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=neovim-matchparen-git
+_pkg="${pkgname%-git}"
+pkgver=r137.6860f53
+pkgrel=1
+pkgdesc='Alternative neovim matchparen plugin'
+arch=('any')
+url="https://github.com/monkoose/matchparen.nvim"
+license=('MIT')
+groups=('neovim-plugins')
+depends=('neovim')
+makedepends=('git')
+provides=("$_pkg")
+conflicts=("$_pkg")
+install=matchparen.install
+source=("$_pkg::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkg"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" )
+}
+
+package() {
+ cd "$_pkg"
+ find doc lua -type f -exec install -Dm644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
diff --git a/matchparen.install b/matchparen.install
new file mode 100644
index 000000000000..867d656caf9f
--- /dev/null
+++ b/matchparen.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo ':: This plugin requires manual setup.'
+ echo ':: Consult upstream documentation for more information.'
+ echo ':: A copy has been installed under /usr/share/doc/neovim-matchparen-git/README.md for your reference.'
+}
+
+post_remove() {
+ echo ':: Remember to remove all references to this plugin from your init scripts.'
+}