summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormmh2020-06-02 02:31:36 +0200
committermmh2020-06-02 02:31:36 +0200
commit0fb39a25aabcaec3710fbb664e02d7e55b8ac2b6 (patch)
tree532f3f3f2121f7d7b975914d6f8d9604ef4c9dee
downloadaur-0fb39a25aabcaec3710fbb664e02d7e55b8ac2b6.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..053a054fdc3a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = neovim-minpac-git
+ pkgdesc = A minimal package manager for Neovim
+ pkgver = v2.0.1.r20.544f2e6
+ pkgrel = 1
+ url = https://github.com/k-takata/minpac
+ arch = any
+ groups = neovim-plugins
+ license = custom:VIM
+ license = custom:MIT
+ makedepends = git
+ provides = neovim-minpac
+ conflicts = neovim-minpac
+ source = git+https://github.com/k-takata/minpac.git
+ sha256sums = SKIP
+
+pkgname = neovim-minpac-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..884f106d34c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: mmh <aur@with-h.at>
+
+_pkgname="minpac"
+
+pkgname="neovim-${_pkgname}-git"
+pkgver=v2.0.1.r20.544f2e6
+pkgrel=1
+pkgdesc="A minimal package manager for Neovim"
+arch=('any')
+url="https://github.com/k-takata/minpac"
+license=('custom:VIM' 'custom:MIT')
+groups=('neovim-plugins')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+https://github.com/k-takata/${_pkgname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -d "${pkgdir}/usr/share/nvim/site/pack/minpac/opt/minpac"
+ cp -r 'autoload' "${pkgdir}/usr/share/nvim/site/pack/minpac/opt/minpac"
+ cp -r 'doc' "${pkgdir}/usr/share/nvim/site/pack/minpac/opt/minpac"
+ cp -r 'plugin' "${pkgdir}/usr/share/nvim/site/pack/minpac/opt/minpac"
+ install -D 'README.md' "${pkgdir}/usr/share/doc/neovim-minpac/README.md"
+ # No LICENSE file provided by upstream
+}