summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-10-16 03:32:45 -0500
committerLuis Martinez2021-10-16 03:32:45 -0500
commitc79fa952577733628c1bd769f6ffa2f854922e9d (patch)
tree47b988a7860b7ee2525b2927de654fd7f63c13f9
downloadaur-neovim-neorg-git.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD33
-rw-r--r--neorg.install9
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..372edb2dcb27
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = neovim-neorg-git
+ pkgdesc = Org-mode inspired life organization tool
+ pkgver = r388.376e3e6
+ pkgrel = 1
+ url = https://github.com/nvim-neorg/neorg
+ install = neorg.install
+ arch = any
+ groups = neovim-plugin
+ license = GPL3
+ makedepends = git
+ depends = neovim>=0.5
+ depends = neovim-plenary
+ optdepends = neovim-tree-sitter
+ optdepends = neovim-cmp: completion engine
+ provides = neovim-neorg
+ provides = neovim-cmp-neorg
+ conflicts = neovim-neorg
+ conflicts = neovim-cmp-neorg
+ source = neovim-neorg-git::git+https://github.com/nvim-neorg/neorg
+ md5sums = SKIP
+
+pkgname = neovim-neorg-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6feb7c8706f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=neovim-neorg-git
+pkgver=r388.376e3e6
+pkgrel=1
+pkgdesc="Org-mode inspired life organization tool"
+arch=('any')
+url="https://github.com/nvim-neorg/neorg"
+license=('GPL3')
+groups=('neovim-plugin')
+depends=('neovim>=0.5' 'neovim-plenary')
+optdepends=(
+ 'neovim-tree-sitter'
+ 'neovim-cmp: completion engine')
+makedepends=('git')
+provides=("${pkgname%-git}" 'neovim-cmp-neorg')
+conflicts=("${pkgname%-git}" 'neovim-cmp-neorg')
+install=neorg.install
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+PURGE_TARGETS=('tags')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ find doc docs ftdetect lua queries -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
diff --git a/neorg.install b/neorg.install
new file mode 100644
index 000000000000..588c0e3e5e3f
--- /dev/null
+++ b/neorg.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo ':: This plugin requires manual setup.'
+ echo ':: Consult upstream documentation for more information.'
+ echo ':: A copy has been installed under /usr/share/doc/neovim-neorg-git/README.md for your reference.'
+}
+
+post_remove() {
+ echo ':: Remember to remove all references to this plugin from your init scripts.'
+}