summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Karmanov2024-01-14 20:56:25 +0300
committerAnton Karmanov2024-01-14 20:56:25 +0300
commitcc94fe5ea4bc5997a213d3858bfb08322476e24d (patch)
treeeaf96ab6bdc57f4310bff4a88eb814d24aae2e46
downloadaur-cc94fe5ea4bc5997a213d3858bfb08322476e24d.tar.gz
Initial v3.8.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD36
-rw-r--r--neovim-nightfox.install4
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e796f92956e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = neovim-nightfox
+ pkgdesc = Highly customizable Neovim theme with support for a variety of plugins
+ pkgver = 3.8.0
+ pkgrel = 1
+ url = https://github.com/EdenEast/nightfox.nvim
+ install = neovim-nightfox.install
+ arch = any
+ groups = neovim-plugins
+ license = MIT
+ depends = neovim
+ source = neovim-nightfox-3.8.0.tar.gz::https://github.com/EdenEast/nightfox.nvim/archive/v3.8.0.tar.gz
+ md5sums = edd268d432292587f3d1691f26a52c58
+
+pkgname = neovim-nightfox
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..294282566a36
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Anton Karmanov <a.karmanov@inventati.org>
+
+# shellcheck disable=SC2034,SC2164
+
+pkgname='neovim-nightfox'
+_projname='nightfox.nvim'
+pkgver='3.8.0'
+pkgrel=1
+pkgdesc='Highly customizable Neovim theme with support for a variety of plugins'
+arch=('any')
+url="https://github.com/EdenEast/${_projname}"
+license=('MIT')
+groups=('neovim-plugins')
+depends=('neovim')
+install='neovim-nightfox.install'
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+md5sums=('edd268d432292587f3d1691f26a52c58')
+
+package() {
+ pkgdir=${pkgdir:?}
+ local dirs=(autoload colors doc extra lua misc plugin test)
+ local docs=(usage.md CHANGELOG.md)
+
+ cd "${_projname}-${pkgver}"
+
+ find "${dirs[@]}" -type f -exec install -Dvm644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dvm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ for file in "${docs[@]}"; do
+ install -Dvm644 "$file" -t "$pkgdir/usr/share/doc/$pkgname/"
+ done
+}
+
+check() {
+ cd "${_projname}-${pkgver}"
+ make test
+}
diff --git a/neovim-nightfox.install b/neovim-nightfox.install
new file mode 100644
index 000000000000..b9cb1482a9ca
--- /dev/null
+++ b/neovim-nightfox.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo 'Nightfox provides multiple flavours which are named colorschemes:'
+ echo 'nightfox, dayfox, dawnfox, duskfox, nordfox, terafox, carbonfox'
+}