summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Del Castillo2020-12-27 14:07:09 -0500
committerKevin Del Castillo2020-12-27 14:07:09 -0500
commit2284eccbc9ce549aecd72c26c39ade94fdc9e53d (patch)
tree8da50dff1ef45f68bd39669285da3ad7463607ea
downloadaur-2284eccbc9ce549aecd72c26c39ade94fdc9e53d.tar.gz
updpkg: latest version 0.5.0+dev+973+gc64cce906
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD42
-rw-r--r--neovim.install15
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3999b2385f6c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = neovim-nightly-bin
+ pkgdesc = Fork of Vim aiming to improve user experience, plugins, and GUIs - Nightly Builds
+ pkgver = 0.5.0+dev+973+gc64cce906
+ pkgrel = 1
+ url = https://neovim.io
+ install = neovim.install
+ arch = x86_64
+ license = custom:neovim
+ optdepends = python2-neovim: for Python 2 plugin support, see :help python
+ optdepends = python-neovim: for Python 3 plugin support, see :help python
+ optdepends = xclip: for clipboard support, see :help clipboard
+ optdepends = xsel: for clipboard support, see :help clipboard
+ provides = neovim=0.5.0
+ conflicts = neovim
+ source = neovim-0.5.0+dev+973+gc64cce906.tar.gz::https://github.com/neovim/neovim/releases/download/nightly/nvim-linux64.tar.gz
+ sha512sums = SKIP
+
+pkgname = neovim-nightly-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f9a0bab5b98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Kevin Del Castillo <quebin31@gmail.com>
+
+_pkgname=neovim
+_pkgver=0.5.0
+pkgname=neovim-nightly-bin
+pkgver=0.5.0+dev+973+gc64cce906
+pkgrel=1
+pkgdesc='Fork of Vim aiming to improve user experience, plugins, and GUIs - Nightly Builds'
+arch=('x86_64')
+url='https://neovim.io'
+license=('custom:neovim')
+provides=("${_pkgname}=${_pkgver}")
+conflicts=("${_pkgname}")
+optdepends=('python2-neovim: for Python 2 plugin support, see :help python'
+ 'python-neovim: for Python 3 plugin support, see :help python'
+ 'xclip: for clipboard support, see :help clipboard'
+ 'xsel: for clipboard support, see :help clipboard')
+
+source=("$_pkgname-$pkgver.tar.gz::https://github.com/neovim/neovim/releases/download/nightly/nvim-linux64.tar.gz")
+sha512sums=(SKIP)
+install=neovim.install
+
+check() {
+ cd "${srcdir}/nvim-linux64"
+ ./bin/nvim --version
+ ./bin/nvim --headless -u NONE -i NONE -c ':quit'
+}
+
+package() {
+ cd "${srcdir}/nvim-linux64"
+
+ mkdir -p "${pkgdir}/usr/bin"
+
+ cp -r share "${pkgdir}/usr/"
+ install bin/nvim "${pkgdir}/usr/bin"
+
+ # Make Arch vim packages work
+ mkdir -p "${pkgdir}"/usr/share/vim
+ echo "set runtimepath+=/usr/share/vim/vimfiles" > "${pkgdir}"/usr/share/nvim/sysinit.vim
+}
+
+# vim:set sw=2 sts=2 et:
diff --git a/neovim.install b/neovim.install
new file mode 100644
index 000000000000..7d7f32f98325
--- /dev/null
+++ b/neovim.install
@@ -0,0 +1,15 @@
+# $1: new package version
+post_install() {
+ echo ":: The Neovim executable is called 'nvim'."
+ echo ":: If you are already familiar with Vim, see ':help nvim-from-vim'"
+ echo " to get started."
+}
+
+post_upgrade() {
+ echo ":: If you have any questions, check the following page first:"
+ echo " https://github.com/neovim/neovim/wiki/FAQ"
+ echo ":: Remember this a pre-release build, see 'Following HEAD' for more info"
+ echo " https://github.com/neovim/neovim/wiki/Following-HEAD"
+}
+
+# vim:set sw=2 sts=2 et: